Board index » cppbuilder » TListView Column does not paint well

TListView Column does not paint well

Hi, All,

When TListView control has no items
it does not paint the column well.

I want your help.

Thanks.

 

Re:TListView Column does not paint well


Hi!

How about a description of what it looks like (please do not attach a
bitmap to your response, just describe what looks wrong).

------
Mark Cashman, TeamB C++ Builder
http://www.temporaldoorway.com/programming/index.htm
C++ Builder, JBuilder programming information
Home of The C++ Builder Programmer's Webring - Join us!
------

Re:TListView Column does not paint well


I have TListView that has 3 columns
and at the runtime i set column-header's caption on FormCreate event .

then som regions of the column header is not painted.

When i click the column header or the form is activated again
all the region of the column header is painted well at then.

for example, the backslashed region is not painted at its first show.

TListView
-------------------------------
|        _____|_________ |             |
|      ///////////////////////             |   <== Column Header
|------------------------------
|
|

Mark Cashman (TeamB) <markcash...@snet.net>(?) ??? ?T????|
news:38BADAD2.53DEB16C@snet.net?? ????????.

Quote
> Hi!

> How about a description of what it looks like (please do not attach a
> bitmap to your response, just describe what looks wrong).

> ------
> Mark Cashman, TeamB C++ Builder
> http://www.temporaldoorway.com/programming/index.htm
> C++ Builder, JBuilder programming information
> Home of The C++ Builder Programmer's Webring - Join us!
> ------

Re:TListView Column does not paint well


Hi!

You can try forcing a repaint by calling Update or Invalidate on the
control.

------
Mark Cashman, TeamB C++ Builder
http://www.temporaldoorway.com/programming/index.htm
C++ Builder, JBuilder programming information
Home of The C++ Builder Programmer's Webring - Join us!
------

Other Threads