Board index » cppbuilder » debug and singlestep

debug and singlestep


2007-02-16 04:23:24 PM
cppbuilder93
Hello
I have a program, where the blue dots at the left site (showed when running in debug mode) are only showed in some of the files.
In the file where they are not showed, I cannot set a breakpoint.
If I set a breakpoint just before entering the file without the blue dots, then I can singlestep in the file, and see values of variabels. I have tried to delete the tds. file a rebuild, but it doesn't help. Why is that?
Best Regards
Kresten
 
 

Re:debug and singlestep

On 16 Feb 2007 00:23:24 -0800, "Kresten Tolstrup" < XXXX@XXXXX.COM >
wrote:
Quote

Hello

I have a program, where the blue dots at the left site (showed when running in debug mode) are only showed in some of the files.
In the file where they are not showed, I cannot set a breakpoint.
If I set a breakpoint just before entering the file without the blue dots, then I can singlestep in the file, and see values of variabels. I have tried to delete the tds. file a rebuild, but it doesn't help. Why is that?

Best Regards
Kresten
You may have local options set for that file, so that it generates no
debug information.
zara
 

Re:debug and singlestep

"Kresten Tolstrup" < XXXX@XXXXX.COM >wrote:
Quote
I have a program, where the blue dots at the left site (showed
when running in debug mode) are only showed in some of the
files. In the file where they are not showed, I cannot set a
breakpoint. If I set a breakpoint just before entering the
file without the blue dots, then I can singlestep in the file,
and see values of variabels. I have tried to delete the tds.
file a rebuild, but it doesn't help. Why is that?
Maybe a problem with two files equally named, but in different
folders? Check your project if the file compiled is the same
file you see.
 

{smallsort}

Re:debug and singlestep

"Thorsten Kettner" < XXXX@XXXXX.COM >wrote:
Quote

"Kresten Tolstrup" < XXXX@XXXXX.COM >wrote:
>I have a program, where the blue dots at the left site (showed
>when running in debug mode) are only showed in some of the
>files. In the files where they are not showed, I cannot set a
>breakpoint. If I set a breakpoint just before entering the
>file without the blue dots, then I can singlestep in the file,
>and see values of variabels. I have tried to delete the tds.
>file a rebuild, but it doesn't help. Why is that?

Maybe a problem with two files equally named, but in different
folders? Check your project if the file compiled is the same
file you see.
No that is not the problem, it is the same file, but I have also tried to remove the file from the project, and then add it again, it doesn´t help.
Best Regards
Kresten
 

Re:debug and singlestep

Quote
>"Kresten Tolstrup" < XXXX@XXXXX.COM >wrote:
>>I have a program, where the blue dots at the left site
>>(showed when running in debug mode) are only showed in some
>>of the files. In the files where they are not showed, I
>>cannot set a breakpoint.
Funny, just yesterday I suddenly got the same problem. The only
thing I had changed was to specify another exe folder in project
options. Then a colleague of mine gave me the advice to delete
the project's dsk file. And that solved the issue. Maybe it
helps in your case, too.