Board index » cppbuilder » TImageList causing Linker to Hang

TImageList causing Linker to Hang


2006-06-23 12:04:05 AM
cppbuilder64
Sounds strange but as soon as I add an image, with the Image List Editor, to my TImageList the program fails to link.
The linker just hangs. If there are no images in the list it works. Any suggestions?
 
 

Re:TImageList causing Linker to Hang

The problem is not in TImageList (I have tried and it works).
The problem is the instability of the linker which can quit with an AV or
give some mysterious warnings or whatever.
My suggestion is to file a report to the Quality Central and to continue
trolling around until something happens.
And do not listen to those who say that reporting a problem without
submitting a test case permitting to reproduce the problem is useless. IT IS
NOT and specially in this case IT IS IMPOSSIBLE.
(When my program becomes unstable, I just translate it with CodeGuard on and
after a good debugging session it is stable again. Maybe should DevCo apply
their own medecine.)
Pavel
"Joan" < XXXX@XXXXX.COM >píše v diskusním příspěvku
Quote

Sounds strange but as soon as I add an image, with the Image List Editor,
to my TImageList the program fails to link.
The linker just hangs. If there are no images in the list it works. Any
suggestions?
 

Re:TImageList causing Linker to Hang

You have not mentioned what version of the compiler you are using.
If you are using a version of the compiler that is less than 6, then the
item you are adding may sum with the other resources to a size which exceeds
the resource size it can handle. Resource size capacity was increased in
BCB 6.
. Ed
Quote
Joan wrote in message
news:449abf75$ XXXX@XXXXX.COM ...

Sounds strange but as soon as I add an image, with the Image
List Editor, to my TImageList the program fails to link. The linker
just hangs. If there are no images in the list it works. Any
suggestions?
 

{smallsort}

Re:TImageList causing Linker to Hang

On Fri, 23 Jun 2006 14:16:15 +0200, "Pavel Sobek" < XXXX@XXXXX.COM >
wrote:
Quote
The problem is the instability of the linker which can quit with an AV or
give some mysterious warnings or whatever.
My suggestion is to file a report to the Quality Central and to continue
trolling around until something happens.
my suggestion is to switch from ilink to ulink just as I did. by doing
this I not only got rid of all those linker troubles but also reduced
linking time from approx. 2 minutes downto ~5 secs in one of my
projects, reduced exe and tds size significantly. feel the difference
of real quality :)
--
Vladimir Ulchenko aka vavan