Board index » cppbuilder » VPN network issue

VPN network issue


2005-08-15 09:38:25 PM
cppbuilder41
We have a VPN that connects all our offices around the world. Some time
in the last six months something changed that has broken one of our
applications. The application uses TCustomWinSocket in non-blocking
mode to send data.
The application works fine within a single office (not terribly
helpful) but experiences difficulty between different offices. The
symptoms are:
* Terrible performance.
Commands appear to be being received a dozen or more seconds after they
have actually been sent. It incorporates a simple chat client but the
delay is unbelievable. Typically typing 'hello' and pressing [return]
results in the string appearing at the other end after over 20 seconds!
It can even appear after the sender closed the connection but then the
reporting of the closed connection takes 20 seconds. It's like there's
a time delay in the network :-/
* Packet blockage.
Some commands simply never get transmitted at all. Oddly it seems to be
the server responses that never get sent. This is weird. The server
will always (eventually!) see the client request and respond to it but
the client never sees the server acknowledgement packet. This is true
no matter where the client/server are located.
Obviously this is some kind of network configuration issue but our IT
guy isn't aware of any change. We're stumped. FWIW we also have
commercial proxy software and this is still working.
Can anyone shed any light on where we might look to investigate this?
--
Andrue Cope [TeamB]
[Bicester, Uk]
info.borland.com/newsgroups/guide.html
 
 

Re:VPN network issue

Andrue Cope [TeamB] wrote:
Quote
The application works fine within a single office (not terribly
helpful) but experiences difficulty between different offices.
Ah, FWIW each offices has its own firewall.
--
Andrue Cope [TeamB]
[Bicester, Uk]
info.borland.com/newsgroups/guide.html
 

Re:VPN network issue

On 15 Aug 2005 06:38:25 -0700, you wrote:
Quote
We have a VPN that connects all our offices around the world. Some time
in the last six months something changed that has broken one of our
applications. The application uses TCustomWinSocket in non-blocking
mode to send data.

* Terrible performance.
Commands appear to be being received a dozen or more seconds after they
have actually been sent. It incorporates a simple chat client but the
You didn't accidentally turn on buffering, did you?
Small packets can get delayed if TCP is waiting for a full buffer
before sending.
I know next to nothing about firewalls (other than they seem to work),
but maybe they've been "upgraded" to stop pesky DOS attacks of swarms
of small packets. Throwing out the good ones with the "bad".
(You may or may not accidentally receive a copy of this in email)
 

{smallsort}

Re:VPN network issue

Bob Gonder wrote:
Quote
You didn't accidentally turn on buffering, did you?
That's an interesting idea, I'll pass that one. It doesn't help that
atm our main IT guy is in America and is using Proxy to control our
firewall. It makes it awkward :)
--
Andrue Cope [TeamB]
[Bicester, Uk]
info.borland.com/newsgroups/guide.html