Board index » cppbuilder » Problem in TFrame constructor

Problem in TFrame constructor


2005-11-28 10:59:47 PM
cppbuilder8
Hello,
I am asking here because I was not able to find an answer using Google. I
have a TFrame that I added some code and controls today. I copied a TPanel
from another application of mine but suddenly a problem started:
In the constructor of the frame,
__fastcall THttpServerFrame::THttpServerFrame(TComponent* Owner, String
serverName) : TFrame(Owner) // constructor of THttpServerFrame
before it executes code of mine, the flow passes to the constructor of the
base class (TFrame) which is normal BUT in Forms.hpp'de,
public:
#pragma option push -w-inl
/* TCustomFrame.Create */ inline __fastcall virtual
TFrame(Classes::TComponent* AOwner) : TCustomFrame(AOwner) { } // here
#pragma option pop
it gives EReadError "Invalid Property Value" exception. I looked at the DFM
text code and saw nothing wrong. I have multiple code directories with some
code shared with the other project but that did not reveal any hint as well.
Any idea what's wrong?
Best Regards,
SubZ
 
 

Re:Problem in TFrame constructor

Thanks anyway for reading. I figured out. It was a paths problem.
"SubZ" < XXXX@XXXXX.COM >wrote in message
: Hello,
:
: I am asking here because I was not able to find an answer using Google. I
: have a TFrame that I added some code and controls today. I copied a TPanel
: from another application of mine but suddenly a problem started:
:
: In the constructor of the frame,
:
: __fastcall THttpServerFrame::THttpServerFrame(TComponent* Owner, String
: serverName) : TFrame(Owner) // constructor of THttpServerFrame
:
: before it executes code of mine, the flow passes to the constructor of the
: base class (TFrame) which is normal BUT in Forms.hpp'de,
:
: public:
: #pragma option push -w-inl
: /* TCustomFrame.Create */ inline __fastcall virtual
: TFrame(Classes::TComponent* AOwner) : TCustomFrame(AOwner) { } // here
: #pragma option pop
:
: it gives EReadError "Invalid Property Value" exception. I looked at the
DFM
: text code and saw nothing wrong. I have multiple code directories with
some
: code shared with the other project but that did not reveal any hint as
well.
: Any idea what's wrong?
:
: Best Regards,
:
: SubZ
:
: