Board index » cppbuilder » Question marks in debug inspector?

Question marks in debug inspector?


2003-08-26 07:22:55 AM
cppbuilder97
Hello all,
Ok, this has been driving me nuts... When I use the Debug Inspector and I
get two good
addresses at the top but all the entries are question marks.. What does it
mean?? I'm inspecting
a structure...
Apparently the pointer to the structure is not null. Anyway I'd at least
like to know
what the Debug Inspector means with the question marks??
Thanks a lot,
Bruce Larrabee
 
 

Re:Question marks in debug inspector?

"chip" < XXXX@XXXXX.COM >wrote in message
Quote
When I use the Debug Inspector and I get two good addresses
at the top but all the entries are question marks.. What does it
mean??
The contents are unknown, usually because you are inspecting a NULL pointer,
or invalid addresses. Just because you have a non-NULL address does not
necessarily mean that it is a valid address.
Gambit
---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (www.grisoft.com).
Version: 6.0.512 / Virus Database: 309 - Release Date: 8/19/03
 

Re:Question marks in debug inspector?

"chip" < XXXX@XXXXX.COM >writes:
Quote
Hello all,

Ok, this has been driving me nuts... When I use the Debug Inspector
and I get two good addresses at the top but all the entries are
question marks.. What does it mean?? I'm inspecting a structure...

Apparently the pointer to the structure is not null. Anyway I'd at
least like to know what the Debug Inspector means with the question
marks??
It could mean that the variable is out of scope. (Doesn't
currently/yet exist.)
--
Chris(TeamB);
 

{smallsort}