Board index » cppbuilder » Application Icon

Application Icon


2003-09-19 07:32:23 PM
cppbuilder70
For some very odd reason, the "Load Icon" button on the Application tab of
Project Options is greyed out for my Win32 .Exe running under Windows XP,
but not under Win98SE. Any ideas?
--
Mark Jacobs
XXXX@XXXXX.COM
www.dkcomputing.co.uk
 
 

Re:Application Icon

Hi there
under Project->Options->Application the placed to load an icon is greyed
out. Why is this?
Thanks
Neil
 

Re:Application Icon

Neil wrote:
Quote
under Project->Options->Application the placed to load an icon is
greyed out. Why is this?
What kind of project have you created?
Is this a Windows app, a web app, a console app?
AlisdairM
 

{smallsort}

Re:Application Icon

Neil wrote:
Quote
it is a windows app.
In which case you'll hate the next tip but...
Have you tried recreating the project?
Make a new project, add all the source, fix options etc.
I know this is painful for a project of any size, but it often fixes
strange problems that fall out of the .bpr file.
IF this works, I would be interested to hear of any difference between
the two project files.
If not, time to don my thinking cap...
AlisdairM
 

Re:Application Icon

it is a windows app.
"Alisdair Meredith (TeamB)"
< XXXX@XXXXX.COM >wrote in message
Quote
What kind of project have you created?
Is this a Windows app, a web app, a console app?


AlisdairM
 

Re:Application Icon

"Alisdair Meredith (TeamB)"
< XXXX@XXXXX.COM >wrote in message
Quote
In which case you'll hate the next tip but...

Have you tried recreating the project?

Make a new project, add all the source, fix options etc.

I know this is painful for a project of any size, but it often fixes
strange problems that fall out of the .bpr file.

IF this works, I would be interested to hear of any difference between
the two project files.

If not, time to don my thinking cap...

AlisdairM
I give it a try and see what happens
 

Re:Application Icon

"Alisdair Meredith (TeamB)"
< XXXX@XXXXX.COM >wrote in message
Quote
Neil wrote:

>it is a windows app.

In which case you'll hate the next tip but...

Have you tried recreating the project?

Make a new project, add all the source, fix options etc.

I know this is painful for a project of any size, but it often fixes
strange problems that fall out of the .bpr file.

IF this works, I would be interested to hear of any difference between
the two project files.

If not, time to don my thinking cap...

AlisdairM
Ok, I have just created a new project, I could add an icon to the new
project, but once I built it, the icon was gone and the option was greyed
out again.
 

Re:Application Icon

I'm probably behind the times here - but congrats to Alisdair on TeamB.
Flavio can't be working him hard enough!
Mike
 

Re:Application Icon

Hi,
for some reason my application lost it's icon. I assume something I did made
it change type of application or something. Anyways, the Load Icon button is
greyed out, how can I restore this to the normal application format so it
uses an icon again?
Thanks
 

Re:Application Icon

Hi,
Quote
it change type of application or something. Anyways, the Load Icon button is
greyed out, how can I restore this to the normal application format so it
uses an icon again?
Did you maybe delete or lose <ProjectName>.res? If so, go to Project
Options and turn ON Version Info as that can force a check that .res
still exists.
--Craig
 

Re:Application Icon

Yeah thanks, silly me had removed the .res file from the project.
Thanks Craig
 

Re:Application Icon

Hi
I have a problem with the Application Icon.
The icon does not appear in the main window and in the task bar. The
.res for the project is avaible and the icon is in there (as MAINICON).
I've also opened the .exe with a resource viewer, the icon exists there
as MAINICON. I've also tested the icon with another C++ Builder
application. There it works well.
Does anyone have information about this problem?
Tanks for your help
Regards
Patrik
 

Re:Application Icon

I'm using JBuilder to build a Windows application. I'm deploying it to my first round of test users now. Although the deployment works just fine, I can't seem to find a way to change the JBuilder logo that is the application desktop icon and minimization icon. I've got the icon I want in place, and I'm using it for the frame icon. How can I set it to be the desktop icon?
Thanks!
Rod
 

Re:Application Icon

Rod Frey wrote:
Quote
I'm using JBuilder to build a Windows application. I'm deploying it
to my first round of test users now. Although the deployment works
just fine, I can't seem to find a way to change the JBuilder logo
that is the application desktop icon and minimization icon. I've got
the icon I want in place, and I'm using it for the frame icon. How
can I set it to be the desktop icon?

Thanks! Rod
This topic has been covered several times. See the search below (watch
for wrapping on the link).
www.google.ca/groups&lr=&num=20&hl=en
--
Regards,
Lori Olson [TeamB]
------------
Save yourself, and everyone else, some time and search the
newsgroups and the FAQ-O-Matic before posting your next
question.
Google Advanced Newsgroup Search
www.google.ca/advanced_group_search
Other Newsgroup Searches:
www.borland.com/newsgroups/ngsearch.html
Joi Ellis's FAQ-O-Matic:
www.visi.com/~gyles19/fom-serve/cache/1.html