Board index » cppbuilder » Spirit 1.8.0 drops support for ill conforming compilers

Spirit 1.8.0 drops support for ill conforming compilers


2004-02-06 11:22:04 PM
cppbuilder48
The thing is, even when I can get to spirit.sf.net, which seems to be
overloaded, I cannot find any definite list of what is supported and what is
not. Does this mean _all_ Borland compilers are ill conforming? Does
anybody here know?
At least I can stick to 1.6
Robert Kindred
 
 

Re:Spirit 1.8.0 drops support for ill conforming compilers

"Robert Kindred" < XXXX@XXXXX.COM >wrote in message
Quote
Does this mean _all_ Borland compilers are ill conforming? Does
anybody here know?
To date Borland has not made a conforming C++ compiler, but then again
neither has anyone else except perhaps Comeau. The real question is
whether the compiler is "conformant enough" to compile Spirit 1.8.
Probably no currently available Borland compiler is, but they are
working on a new one that's available in preview form for C++BuilderX.
If that one can't already build Spirit 1.8, I suspect that it will be
able to soon.
--
Gillmer J. Derge (TeamB)
 

Re:Spirit 1.8.0 drops support for ill conforming compilers

BCB6 is not conforming enough to compile Spirit 1.8
Users of BCB6 and VC6 should stick with the Spirit 1.6 release. The 1.6
release will be maintained (to some degree) and some of the new features in
1.8 will be back-ported into 1.6
Mark Finkle
 

{smallsort}