Board index » cppbuilder » Project->Options->Application->Application settings...

Project->Options->Application->Application settings...

I am experiencing some difficulty with setting the application settings
(title, help file, icon) in the Project->Options->Application dialog box.  I
had them set and then now they're greyed out and blank and I cannot set
them.  Can anyone give me an idea of what the problem may be?

Also, during compiling, sometimes I get these exceptions from the compile
itself, and subsequent compilations give the same message (I am unable to
duplicate it right this moment to give you the exact message, since it
happens only occasionally).  Closing BCB and then restarting would work, and
the file compiles fine as well.  This isn't a big problem, but it's quite a
hassle when I have to close and re-open and wait for the compile again and
again (since the first one takes forever!).

Thanks for any help you can give me!

--Bryant
bryant.c...@asu.edu

 

Re:Project->Options->Application->Application settings...


: "Bryant Chan" <brya...@az.rmci.net> wrote:

Quote
>I am experiencing some difficulty with setting the application settings
>(title, help file, icon) in the Project->Options->Application dialog box.  I
>had them set and then now they're greyed out and blank and I cannot set
>them.  Can anyone give me an idea of what the problem may be?

If you have a DLL project that is normal.

Quote
>Also, during compiling, sometimes I get these exceptions from the compile
>itself,

Without the exact error message there is nothing that I could say here.

--
Stefan Hoffmeister (TeamB)     http://www.econos.de/
Please do apply judgement when sending email.

Re:Project->Options->Application->Application settings...


Stefan Hoffmeister (TeamB) <Stefan.Hoffmeis...@Econos.de> wrote in message
news:37623e7e.1452999@forums.inprise.com...

Quote

> If you have a DLL project that is normal.

That's just it; I don't have a DLL project.  It began as a regular
application and has remained so since.  I was able to set them at first, but
they have been grayed out during the interim.  Anyway, there wouldn't be any
problem in using Application->Title, Application->HelpFile, and
Application->Icon, since that's what it basically does, right?

Quote

> Without the exact error message there is nothing that I could say here.

I seem to remember something about access violations, and it would
repeatedly show up until I would exit BCB and then return.  The next time it
happens, I'll post the exact error message.  Thanks!

Quote
> --
> Stefan Hoffmeister (TeamB)     http://www.econos.de/
> Please do apply judgement when sending email.

Bryant Chan
bryant.c...@asu.edu

Re:Project->Options->Application->Application settings...


: "Bryant Chan" <brya...@az.rmci.net> wrote:

Quote
>Anyway, there wouldn't be any
>problem in using Application->Title, Application->HelpFile, and
>Application->Icon, since that's what it basically does, right?

There really shouldn't be, no.

--
Stefan Hoffmeister (TeamB)     http://www.econos.de/
Please do apply judgement when sending email.

Re:Project->Options->Application->Application settings...


Bryant,

You can get odd behavior for things like the Icon and Version
Info settings when the projects .RES file has been removed.
Did you maybe move the project recently and didn't take
the .RES file with it (it will be the same name as the
project with .RES extension )?--Craig

Re:Project->Options->Application->Application settings...


It's strange behavior, I'll agree.  Once I remove the main form from the
Project Manager, I can once again use the Application Settings window in the
Project Options dialog box.  From there I can load the icon that I want to,
and then Add the main form back into the Proj. Mgr., and the Application
Settings dialog box will once again be greyed out, but the icon still works
(I still, however, have to use Application->Title and Application->HelpFile
to get those working correctly).  Regarding the .RES file, I have not moved
it, I have only added bitmaps to it; however, this behavior was exhibited
even before I began touching the .RES file.

Thx, though, it was a good idea!  Does anyone else have this problem?  Is it
something I'm doing in the main form (or the creation of it) that is causing
it to be greyed out?

Anyway, it's not too important anymore, but I would still like to know why.

Also, does anyone have any idea why, sometimes, when I "Run" or "Build," the
compiler shows that it has read 0 lines and then just locks up?  Basically,
I have lost everything in that session since I cannot recover control and
must use Windows to close the non-responding C++ B3.  Any ideas?

Thx--Bryant

Quote
Craig Farrell <cNO_SPAM.please.farr...@insprise.com> wrote in message

news:376042AF.2127CA37@insprise.com...
Quote
> Bryant,

> You can get odd behavior for things like the Icon and Version
> Info settings when the projects .RES file has been removed.
> Did you maybe move the project recently and didn't take
> the .RES file with it (it will be the same name as the
> project with .RES extension )?--Craig

Re:Project->Options->Application->Application settings...


: "Bryant Chan" <brya...@az.rmci.net> wrote:

Quote
>Regarding the .RES file, I have not moved
>it, I have only added bitmaps to it;

Please don't manipulate the project's RES file. Simply use another RES
file for that very purpose and add it to the project.

Why? Because C++Builder at any time may delete or alter the content of its
"own" RES file.

--
Stefan Hoffmeister (TeamB)     http://www.econos.de/
Please do apply judgement when sending email.

Other Threads