Board index » cppbuilder » WTSSEndMessage strange behavior

WTSSEndMessage strange behavior


2007-10-30 05:47:28 PM
cppbuilder51
Hi there!
Well what i got here - i'm debugging an application which is supposed to work on a terminal server under Win2003. the current machine is WinXp sp2. At present i'm working out the troubles pertaining to WTSSendMessage wildy behavior. The messages are sent within background thread on a server application to a specific session user (its a countdown messages saying about how much minutes user has left). After approximately 6-7 messages thread becomes unstable and i get an access violation errors at a random locations... when i use a regular MessageBox - everything is ok.
Does it has something to do with Xp OS?
Any help would be appreciated.
Andrew.
 
 

Re:WTSSEndMessage strange behavior

solved.
"Andrew" < XXXX@XXXXX.COM >сообщи?сообщила ?новостях следующе?
Quote

Hi there!

Well what i got here - i'm debugging an application which is supposed to
work on a terminal server under Win2003. the current machine is WinXp sp2.
At present i'm working out the troubles pertaining to WTSSendMessage wildy
behavior. The messages are sent within background thread on a server
application to a specific session user (its a countdown messages saying
about how much minutes user has left). After approximately 6-7 messages
thread becomes unstable and i get an access violation errors at a random
locations... when i use a regular MessageBox - everything is ok.

Does it has something to do with Xp OS?
Any help would be appreciated.

Andrew.