Board index » cppbuilder » C++ Builder 6 - Import ActiveX Control Problem with VB6 programmed ActiveX

C++ Builder 6 - Import ActiveX Control Problem with VB6 programmed ActiveX

Hi,

i try to use some VB6 programmed ActiveX Controls in C++ Builder 6.

I use Component Import Active X. Select my Control, put it into a package,
compile the package, install the package. Everything ok, with no warnings or
errors.

But the Control does not show up in the palette.

I found some hints on Hidden flags, Create flags and using TLIBIMP but did
not succed.

Does anybody has similar problems and / or some tips / hints / a solution ?

Is there a way using the ActiveX Control without having it in the palette?

Jochen

 

Re:C++ Builder 6 - Import ActiveX Control Problem with VB6 programmed ActiveX


you can use it with out the palette how ever, your problem maybe due to
no ICON for the palette.
 there should be a resource file with the package open it and see if you have
an bitmap of the name of  the conponent in it.
it should be the same name as the componet etc..
Quote
Jochen Guyot wrote:
> Hi,

> i try to use some VB6 programmed ActiveX Controls in C++ Builder 6.

> I use Component Import Active X. Select my Control, put it into a package,
> compile the package, install the package. Everything ok, with no warnings or
> errors.

> But the Control does not show up in the palette.

> I found some hints on Hidden flags, Create flags and using TLIBIMP but did
> not succed.

> Does anybody has similar problems and / or some tips / hints / a solution ?

> Is there a way using the ActiveX Control without having it in the palette?

> Jochen

Other Threads