Board index » cppbuilder » Web Deployment Options Problem?

Web Deployment Options Problem?

Is there a problem with the Additional Files tab page of the Web
Deployment Options dialog box.  I've tryed just about everything to get
my ActiveForms to work on a client machine when there are additional
files.  I've followed the documentation and examples, but nothing seems
to work.  The only time it works is when I register the ActiveForm on MY
machine and then run it only on MY machine.  If there is a problem, I'd
like Borland to admit it so that I can stop thinking its something I'm
doing wrong.  
I want to use a database in my ActiveForm.  If I ever get it to load
with a database on a client machine, how exactly will it behave?  Will
the new information in the database stay on the client machine?  Will I
be able to get that new information back to the server?  Or will I have
to do some sort of programming with a POP3 server or IP sockets?

 

Re:Web Deployment Options Problem?


It is not a bug in C++Builder, or at least not one that i could
reproduce.  I am able to create an active form, have additional files
(like the runtime library) either included in the same cab file or
others and it works fine.   If you are creating the project so that
all the additional files are in the same cab file, you can see that
everything made it into the cab file by using cabarc L <cabfile>  that
will show you the contents of your cab file.  The other thing to check
is to make sure that all of the files needed to be extracted are
listed in the inf file and that they are extracted from the correct
cab file.

Y.T.
Kevin

On Fri, 27 Mar 1998 08:49:28 -0600, anonymous3

Quote
<anonymo...@anywhere.com> wrote:
>Is there a problem with the Additional Files tab page of the Web
>Deployment Options dialog box.  I've tryed just about everything to get
>my ActiveForms to work on a client machine when there are additional
>files.  I've followed the documentation and examples, but nothing seems
>to work.  The only time it works is when I register the ActiveForm on MY
>machine and then run it only on MY machine.  If there is a problem, I'd
>like Borland to admit it so that I can stop thinking its something I'm
>doing wrong.  
>I want to use a database in my ActiveForm.  If I ever get it to load
>with a database on a client machine, how exactly will it behave?  Will
>the new information in the database stay on the client machine?  Will I
>be able to get that new information back to the server?  Or will I have
>to do some sort of programming with a POP3 server or IP sockets?

Re:Web Deployment Options Problem?


I have the same problem with a very simple ActiveXform containing only a
button !!

Quote
>Is there a problem with the Additional Files tab page of the Web
>Deployment Options dialog box.  I've tryed just about everything to get
>my ActiveForms to work on a client machine when there are additional
>files.  I've followed the documentation and examples, but nothing seems
>to work.  The only time it works is when I register the ActiveForm on MY
>machine and then run it only on MY machine.  If there is a problem, I'd
>like Borland to admit it so that I can stop thinking its something I'm
>doing wrong.
>I want to use a database in my ActiveForm.  If I ever get it to load
>with a database on a client machine, how exactly will it behave?  Will
>the new information in the database stay on the client machine?  Will I
>be able to get that new information back to the server?  Or will I have
>to do some sort of programming with a POP3 server or IP sockets?

Re:Web Deployment Options Problem?


Try not using runtime packages and linking staticly to the rtl.  Also
make sure that your webdeploy options are set correctly.  

Y.T.
Kevin
On Tue, 31 Mar 1998 14:55:28 -0500, "Jonathan Gauthier"

Quote
<webmas...@intermonde.net> wrote:
>I have the same problem with a very simple ActiveXform containing only a
>button !!

>>Is there a problem with the Additional Files tab page of the Web
>>Deployment Options dialog box.  I've tryed just about everything to get
>>my ActiveForms to work on a client machine when there are additional
>>files.  I've followed the documentation and examples, but nothing seems
>>to work.  The only time it works is when I register the ActiveForm on MY
>>machine and then run it only on MY machine.  If there is a problem, I'd
>>like Borland to admit it so that I can stop thinking its something I'm
>>doing wrong.
>>I want to use a database in my ActiveForm.  If I ever get it to load
>>with a database on a client machine, how exactly will it behave?  Will
>>the new information in the database stay on the client machine?  Will I
>>be able to get that new information back to the server?  Or will I have
>>to do some sort of programming with a POP3 server or IP sockets?

Other Threads