Board index » cppbuilder » App Icon does not appear on taskbar?

App Icon does not appear on taskbar?

This is part of the help file on TApplication::Icon property
----------------------------------------------------------------------------
--

    Determines which icon represents the application on the
    Windows task bar.

    __property Graphics::TIcon* Icon = {read=FIcon, write=SetIcon};

    Description

    Use Icon to assign a specific icon to represent the application.
    Set the Icon property by either:

    Assigning it a TIcon at runtime.
    Loading an icon on the Application pages of the Project|Options
    dialog box at design time.

    Icon represents the application when it is minimized and appears
    either on the Windows desktop or task bar.

----------------------------------------------------------------------------
--

I used the menu 'Project|Options' and set the application Icon but
it does not appear on the taskbar at all. In fact when debugging
the Empty property of the Icon reports true. So no icon is available
it is empty.

Anyone any ideas.

Arjan.

 

Re:App Icon does not appear on taskbar?


Hi Arjan,

Quote
> I used the menu 'Project|Options' and set the application Icon but
> it does not appear on the taskbar at all. In fact when debugging
> the Empty property of the Icon reports true. So no icon is available
> it is empty.

This is odd -- perhaps your project resource file is mangled.  Open your
project resource file in ImageEditor, and ensure that the correct icon
is present under the MAINICON identifier.  If you're still having
trouble, try searching http://www.deja.com.  I vaguely remember a
similar problem being reported about a year ago.

Good luck!

--
Damon Chandler
http://bcbcaq.freeservers.com

Re:App Icon does not appear on taskbar?


I found the problem.
It is because I use the cw3245mt.dll instead of cd cp3245mt.dll.
I do not know why this is.

Trying to read the resource my self using a TResourceStream fails because of
an exception.
Even when I try to use windows API functions it fails but the resource is
there when I open the
executable in BC5.02 IDE.

Someone any ideas?

Arjan

Quote
Damon Chandler <dm...@cornell.edu> wrote in message

news:38D5D589.8CA1CA52@cornell.edu...
Quote
> Hi Arjan,
> > I used the menu 'Project|Options' and set the application Icon but
> > it does not appear on the taskbar at all. In fact when debugging
> > the Empty property of the Icon reports true. So no icon is available
> > it is empty.

> This is odd -- perhaps your project resource file is mangled.  Open your
> project resource file in ImageEditor, and ensure that the correct icon
> is present under the MAINICON identifier.  If you're still having
> trouble, try searching http://www.deja.com.  I vaguely remember a
> similar problem being reported about a year ago.

> Good luck!

> --
> Damon Chandler
> http://bcbcaq.freeservers.com

Other Threads