Board index » cppbuilder » CPU Window comes up but no errors

CPU Window comes up but no errors

HI:

  In testing parts of app, I get cpu window popping up and app stops. I click run and
it stops again. Click run second time and app continues correctly.

  Anyone seen this behavior and knows what it is from?

  Thanks.

                                                  Best regards

 

Re:CPU Window comes up but no errors


Hi Robert,
I have seen it.  It comes up on my system when TPrinter::GetHandle is
called.  I have a USB printer.
If I change the default printer to a non-USB printer, the problem disappears
until the USB printer is accessed.
I posted a message a week or two ago. No response.
There seems to have no way to submit a bug report any longer on Borland's
web site and I'm NOT going to pay for the privilege.

--
- Michael
Antispam.Mich...@GillenConsultingGroup.com
remove Antispam. for email

"Robert F. Tulloch" <tult...@ibm.net> wrote in message
news:3A770FBC.F98499F1@ibm.net...

Quote
> HI:

>   In testing parts of app, I get cpu window popping up and app stops. I
click run and
> it stops again. Click run second time and app continues correctly.

>   Anyone seen this behavior and knows what it is from?

>   Thanks.

>                                                   Best regards

Re:CPU Window comes up but no errors


Hi:

Quote
> I have seen it.  It comes up on my system when TPrinter::GetHandle is
> called.  I have a USB printer.
> If I change the default printer to a non-USB printer, the problem disappears
> until the USB printer is accessed.
> I posted a message a week or two ago. No response.

  Thanks for response. It seems to have no effect and app runs fine w/o IDE. Was just
wondering if perhaps it was a sign of a more serious underlying problem in my code. It
appears like a benign bug if that.

                                                            Best regards

Re:CPU Window comes up but no errors


Hi,

Quote
> I get cpu window popping up and app stops

Is that a couple of int 3 breakpoints in NTDLL.DLL?
If so, that behavior has been described with apps
run under other non-Borland de{*word*81}s as well.
It's been blamed on various possibilities including
using COM, Common Dialogs, or Shell API without correct
initialization, and even blamed on a bug in W2K SP1
NTDLL.DLL (hard-coded breakpoints). But that seems
odd or unlikely because it doesn't seem to be seen
in all apps running under a de{*word*81}, only when
they use a certain portion of the API.

--Craig

Re:CPU Window comes up but no errors


The CPU window is displayed whenever an exception is thrown while the app is
running from within the IDE de{*word*81}.

Gambit

"Robert F. Tulloch" <tult...@ibm.net> wrote in message
news:3A770FBC.F98499F1@ibm.net...

Quote
>   In testing parts of app, I get cpu window popping up and app stops. I
click run and
> it stops again. Click run second time and app continues correctly.

>   Anyone seen this behavior and knows what it is from?

Re:CPU Window comes up but no errors


Hi:

Quote
> The CPU window is displayed whenever an exception is thrown while the app is
> running from within the IDE de{*word*81}.

  It does happen when accessing the API. If throwing an exception, why no message?

  Oops. I have Stop on exceptions unchecked. Could that effect it?

  Thanks.

                                                    Best regards

Re:CPU Window comes up but no errors


Hi:

  No difference. Tried codeguard but that screwed up my app with a unresolved external
linker error to something having nothing to do with my project. Ugh!!!!

                                                Best regards

Re:CPU Window comes up but no errors


Yes, I have the exact same problem. I am running BCB5 on Win2k SP1.
I also get four stops on exit. I have no remedy, but I have seen that other
Win2k
users don't have the same problem, and I don't have it with small test apps.

Morten Espeland

"Robert F. Tulloch" <tult...@ibm.net> wrote in message
news:3A770FBC.F98499F1@ibm.net...

Quote
> HI:

>   In testing parts of app, I get cpu window popping up and app stops. I
click run and
> it stops again. Click run second time and app continues correctly.

>   Anyone seen this behavior and knows what it is from?

>   Thanks.

>                                                   Best regards

Other Threads