Board index » cppbuilder » 100% CPU USAGE BY IDE !!!

100% CPU USAGE BY IDE !!!

Hi Everybody!

I use BCB5 Pro Build 12.34 French version.

My BCB5 Pro often hangs when switching from different desktops (dev to debug and
vice versa) when executing my project, which is very annoying!
But today I have noticed one worrying thing : after launching my BCB the CPU
keeps running at 100% !!! (use the system monitor) When running the project it
then drops down to a reasonable value. When terminating the execution and back
to IDE, the CPU usage then stays at low level.

Have you encountered such a trouble? (I don't want my CPU to be burnt by Borland
:-)))) )

/Pascal.

 

Re:100% CPU USAGE BY IDE !!!


Pascal,

Quote
> (I don't want my CPU to be burnt by Borland
> :-)))) )

It won't be. The loading displayed by Task Manager is just how much of the
CPU's time is being spent doing things for Windows. When it's not doing
something for Windows it is still running and at the same speed and power
consumption. The only time the CPU doesn't operate at full speed is when it
drops into power saving mode.

100% CPU utilisation is only an issue if you are trying to run another
application. As long Builder is all that you want to run it is irrelevant.

Andrue Cope
[Bicester, UK]

Re:100% CPU USAGE BY IDE !!!


Hellp Pascal,

Quote
Pascal Gurin wrote:
> Hi Everybody!

> I use BCB5 Pro Build 12.34 French version.

> But today I have noticed one worrying thing : after launching my BCB the CPU
> keeps running at 100% !!!

I had the same problem with BCB4 Pro, when it freezed...
I discovered using precompiled headers may help.
Have a look at www.bcbdev.com

HTH

Regards

J.

Other Threads