Board index » cppbuilder » Timer Problem in ActiveX dll running under VC

Timer Problem in ActiveX dll running under VC

Gentlemen,

I have written an ActiveX dll in BCB6 that is being deployed in a Visual C
service application.  I find that everything works except the Timer.  The
Timer resides on a Datamodule that also contains a Socket component and some
ADO components.  I am using the Timer to send a Heart beat message through
the Socket connection.  When I run through the de{*word*81} I find that
everything is working except that I am not getting any Timer events.  I
enable the Timer at the end of the DatamoduleCreate() method.

I have successfullly used this within a BCB Service, a VB App, and a BCB App
and everything works correctly.  Does any one have a idea or suggestion?  If
you need more information let me know.

Thanks in advance,

Tim

 

Re:Timer Problem in ActiveX dll running under VC


the ttimer maybe using message events wich requires a window.
use the SetTimer api and specify a callback procedure of type STDCALL
Quote
Tim Martin wrote:
> Gentlemen,

> I have written an ActiveX dll in BCB6 that is being deployed in a Visual C
> service application.  I find that everything works except the Timer.  The
> Timer resides on a Datamodule that also contains a Socket component and some
> ADO components.  I am using the Timer to send a Heart beat message through
> the Socket connection.  When I run through the de{*word*81} I find that
> everything is working except that I am not getting any Timer events.  I
> enable the Timer at the end of the DatamoduleCreate() method.

> I have successfullly used this within a BCB Service, a VB App, and a BCB App
> and everything works correctly.  Does any one have a idea or suggestion?  If
> you need more information let me know.

> Thanks in advance,

> Tim

Other Threads