Board index » cppbuilder » Disabled Toolbar Icons displaying incorrectly with Hi Color 16 bit display

Disabled Toolbar Icons displaying incorrectly with Hi Color 16 bit display

I am using BCB5 to develop an app on WIndows XP. Everything works ok on XP
but when I install and run the same app on a Windows 98SE machine the
disabled icons in the toolbar display complete holes where the icon image
was instead of a subtle greyed out image. However in 256 color mode there
are no problems. Also the icons in the menus exhibit the same problems as
they do on the toolbar. I have tried the software on another Windows 98SE
box and I still get the same problem. Also an earlier version of the same
software developed with BCB4 did not have this problem either.

Has anybody experienced this problem?

Many thanks in advance.
Regards
David

 

Re:Disabled Toolbar Icons displaying incorrectly with Hi Color 16 bit display


"David" <dav...@unite.com.au> schreef in bericht
news:3d8421d9@newsgroups.borland.com...

Quote
> I am using BCB5 to develop an app on WIndows XP. Everything works ok on XP
> but when I install and run the same app on a Windows 98SE machine the
> disabled icons in the toolbar display complete holes where the icon image
> was instead of a subtle greyed out image. However in 256 color mode there
> are no problems. Also the icons in the menus exhibit the same problems as
> they do on the toolbar. I have tried the software on another Windows 98SE
> box and I still get the same problem. Also an earlier version of the same
> software developed with BCB4 did not have this problem either.

> Has anybody experienced this problem?

Yes. I don't know what the problem is, Windows or a lazy developer :-). I
have this problem when I only provide one image for a button. When the
button is disabled windows tries to make an greyed image. The results are
not always what you call neat. The solution is to provide two images; one
colorful enabled image and a grayed disabled image.

Other Threads