Board index » jbuilder » Screen Saver causes Jbuilder 9 screen to go blank

Screen Saver causes Jbuilder 9 screen to go blank


2004-01-07 11:04:05 PM
jbuilder19
Several of us are currently having problems with the Jbuilder
IDE when the screen saver comes up. When the screen saver comes
up the JBuilder IDE is all grey out. The only workaround is to
bring up the task manager and kill JBuilder and go back into the
applications. Do you have any ideas what may be causing this?
We are running JBuilder 9 Enterprise with a Dual monitor
configuration.
Thanks....
 
 

Re:Screen Saver causes Jbuilder 9 screen to go blank

I will try it out thank you very much for the information.
"Flip" <[remove] XXXX@XXXXX.COM >wrote:
Quote
Howdy.

>Have you tried going into the <jbuilder>\bin\jdk.config file and
>uncommenting one or more of the parameters used to fix video problems?

I'm also running with a dual monitor setup, and I've seen this for a long
time. I think since JB7 or so. :<

The secret to try out is the \jbuilder9\bin\jdk.config file and play with
the three settings in there.
# vmparam -Dsun.java2d.ddoffscreen=false
# vmparam -Dsun.java2d.noddraw
# vmparam -Dsun.java2d.d3d=false

I would suggest doing one at a time, then start with multiples. I can't
remember exactly which combo worked for me, but I do know I had to use at
least one.

Good luck.


 

Re:Screen Saver causes Jbuilder 9 screen to go blank

Michael Myers wrote:
Quote
Several of us are currently having problems with the Jbuilder
IDE when the screen saver comes up. When the screen saver comes
up the JBuilder IDE is all grey out. The only workaround is to
bring up the task manager and kill JBuilder and go back into the
applications. Do you have any ideas what may be causing this?
We are running JBuilder 9 Enterprise with a Dual monitor
configuration.
Thanks....
I run with a dual monitor setup all the time, and I've never seen this.
Have you tried going into the <jbuilder>\bin\jdk.config file and
uncommenting one or more of the parameters used to fix video problems?
--
Regards,
Lori Olson (TeamB)
------------
Save yourself, and everyone else, some time and search the
newsgroups and the FAQ-O-Matic before posting your next
question.
Google Advanced Newsgroup Search
www.google.ca/advanced_group_search
Other Newsgroup Searches:
www.borland.com/newsgroups/ngsearch.html
Joi Ellis's FAQ-O-Matic:
www.visi.com/~gyles19/fom-serve/cache/1.html
 

{smallsort}

Re:Screen Saver causes Jbuilder 9 screen to go blank

Howdy.
Quote
Have you tried going into the <jbuilder>\bin\jdk.config file and
uncommenting one or more of the parameters used to fix video problems?
I'm also running with a dual monitor setup, and I've seen this for a long
time. I think since JB7 or so. :<
The secret to try out is the \jbuilder9\bin\jdk.config file and play with
the three settings in there.
# vmparam -Dsun.java2d.ddoffscreen=false
# vmparam -Dsun.java2d.noddraw
# vmparam -Dsun.java2d.d3d=false
I would suggest doing one at a time, then start with multiples. I can't
remember exactly which combo worked for me, but I do know I had to use at
least one.
Good luck.
 

Re:Screen Saver causes Jbuilder 9 screen to go blank

Quote
I will try it out thank you very much for the information.
Good luck with it! I am still a bit frustrated that this problem,
specifically with Java interacting to ATI-like drivers still persists today.
:< You'd think they would fix this sooner than later. :<
 

Re:Screen Saver causes Jbuilder 9 screen to go blank

Flip wrote:
Quote
>I will try it out thank you very much for the information.


Good luck with it! I am still a bit frustrated that this problem,
specifically with Java interacting to ATI-like drivers still persists today.
:< You'd think they would fix this sooner than later. :<


"They" being Sun/Java or "They" being ATI?
As long as the two sides continue to point fingers at each other, we
will never see this problem fixed.
--
Regards,
Lori Olson (TeamB)
------------
Save yourself, and everyone else, some time and search the
newsgroups and the FAQ-O-Matic before posting your next
question.
Google Advanced Newsgroup Search
www.google.ca/advanced_group_search
Other Newsgroup Searches:
www.borland.com/newsgroups/ngsearch.html
Joi Ellis's FAQ-O-Matic:
www.visi.com/~gyles19/fom-serve/cache/1.html
 

Re:Screen Saver causes Jbuilder 9 screen to go blank

Quote
"They" being Sun/Java or "They" being ATI?
HA! :>Both actually! :>You caught that one eh?! :>(yup, I'm from CAN
:>)
Quote
As long as the two sides continue to point fingers at each other, we
will never see this problem fixed.
Yup, that's what I mean, both are pointing fingers (from what I'm
seeing/reading :<). And the worst thing is, I'm sure they are equally
guilty and need to work together to fix the problem. Shame.
From what I've read, apparently it's the old driver still being used which
doesn't support directx or the direct draw or the double buffering, etc,
that J2SE Graphics and Graphics2D objects use. However, by now I would have
hoped a new driver (especially with W2K), wouldn't be a problem anymore. :<
But yet with every video driver upgrade I still have to "play" with my JB
settings, and the process reiterates itself when I play with a new JRE. :<
The one thing I'm interested in which maybe you can help me out with is, why
doesn't the JB Help window play well in a dual monitor situation? When I
use the help, and the window is on a single monitor, the position is
remembered (well pretty much, things change when the window is made too
small, but you get the idea). However, once the help window is positioned
on the second monitor, the next time the help window is brought up, it's
straddling both monitors. Why can it not figure out/save the x, y position
properly? Is it an int vs long issue maybe?
 

Re:Screen Saver causes Jbuilder 9 screen to go blank

On 7 Jan 2004 08:04:05 -0700, "Michael Myers"
< XXXX@XXXXX.COM >wrote:
Quote

Several of us are currently having problems with the Jbuilder
IDE when the screen saver comes up. When the screen saver comes
up the JBuilder IDE is all grey out. The only workaround is to
bring up the task manager and kill JBuilder and go back into the
applications.
It may not be the same problem, but FWIW I sometimes see a similar
visual effect and am able to get JB9 to start repainting itself by
resizing its main window.
 

Re:Screen Saver causes Jbuilder 9 screen to go blank

Flip wrote:
Quote
>"They" being Sun/Java or "They" being ATI?

HA! :>Both actually! :>You caught that one eh?! :>(yup, I'm from CAN
:>)

I'm a canuck, too, eh!?
Quote
The one thing I'm interested in which maybe you can help me out with is, why
doesn't the JB Help window play well in a dual monitor situation? When I
use the help, and the window is on a single monitor, the position is
remembered (well pretty much, things change when the window is made too
small, but you get the idea). However, once the help window is positioned
on the second monitor, the next time the help window is brought up, it's
straddling both monitors. Why can it not figure out/save the x, y position
properly? Is it an int vs long issue maybe?


I see that one too. I dealt with a lot of these issues back when I was
a cross-platform C GUI tool vendor. Unfortunately, Microsoft did not
properly specify a lot of details that are used for dual monitor
displays. So the video card drivers tend to implement dual monitor
stuff differently, and it's almost impossible to get something to work
properly across all dual monitor setups.
For instance, one (and only one) video card used to display dialogs
created with my software in a "double wide" mode. It was only the one
video card, so I argued that it was a driver problem. But you just
*try* and get a video card vendor to fix a problem like that...
--
Regards,
Lori Olson (TeamB)
------------
Save yourself, and everyone else, some time and search the
newsgroups and the FAQ-O-Matic before posting your next
question.
Google Advanced Newsgroup Search
www.google.ca/advanced_group_search
Other Newsgroup Searches:
www.borland.com/newsgroups/ngsearch.html
Joi Ellis's FAQ-O-Matic:
www.visi.com/~gyles19/fom-serve/cache/1.html