Board index » jbuilder » Installation error

Installation error


2003-08-19 12:21:45 AM
jbuilder20
I get the following message after installing JBuilder 9 on windows XP
" Fetal Error: Unable to locate package java.lang in classpath or bootclasspath"
Any help would be great...
Thanks
Ben
 
 

Re:Installation error

Ben wrote:
Quote
I get the following message after installing JBuilder 9 on windows XP
" Fetal Error: Unable to locate package java.lang in classpath or bootclasspath"

Any help would be great...

Thanks

Ben
That's generally a sign that your JDK is messed up. Did you do anything
to the JDK after installation? Did you try to reinstall?
--
Regards,
Lori Olson (TeamB)
------------
Save yourself, and everyone else, some time and search the
newsgroups and the FAQ-O-Matic before posting your next
question.
Google Advanced Newsgroup Search
www.google.ca/advanced_group_search
Other Newsgroup Searches:
www.borland.com/newsgroups/ngsearch.html
Joi Ellis's FAQ-O-Matic:
www.visi.com/~gyles19/fom-serve/cache/1.html
 

Re:Installation error

I'm using Borland C++ 5.01 and the InstallShield Express product that came
with it to create an installation CD of my application. In addition to my
app and related data files, I specifiy to do a Complete BDE installation.
Everything goes well during the CD creation, but when installing the app on
a "new" computer (one with no previous Borland or BDE installations), I get
two error messages:
SEVERE:
Merging the configuration files has failed
C:\Program Files\Borland\Common Files\BDE\idapi32.cnf
and
Failed in Adding Alias
The Error Number is 3, Initialization Failure.
Win98 is used on all machines involved. What am I missing on creating the
installation CD?
Thanks,
Rob Graham
 

{smallsort}

Re:Installation error

I'm using Borland C++ 5.01 and the InstallShield Express product that came
with it to create an installation CD of my application. In addition to my
app and related data files, I specifiy to do a Complete BDE installation.
Everything goes well during the CD creation, but when installing the app on
a "new" computer (one with no previous Borland or BDE installations), I get
two error messages:
SEVERE:
Merging the configuration files has failed
C:\Program Files\Borland\Common Files\BDE\idapi32.cnf
and
Failed in Adding Alias
The Error Number is 3, Initialization Failure.
Win98 is used on all machines involved. What am I missing on creating the
installation CD?
Thanks,
Rob Graham
 

Re:Installation error

I'm using Borland C++ 5.01 and the InstallShield Express
product that came with it to create an installation CD of
my application. In addition to my app and related data files,
I specifiy to do a Complete BDE installation. Everything goes
well during the CD creation, but when installing the app on
a "new" computer (one with no previous Borland or BDE
installations), I get two error messages:
SEVERE:
Merging the configuration files has failed
C:\Program Files\Borland\Common Files\BDE\idapi32.cnf
and
Failed in Adding Alias
The Error Number is 3, Initialization Failure.
Win98 is used on all machines involved. What am I missing on
creating the installation CD?
Thanks,
Rob Graham
 

Re:Installation error

Howdy:
When I try to install the foundation edition, the installer unpacks all the
files and then bombs with a Visual C++ error and dumps a file with the
following in it. Any help?
An unexpected exception has been detected in native code outside the VM.
Unexpected Signal : EXCEPTION_ACCESS_VIOLATION (0xc0000005) occurred at
PC=0x3073784
Function=Java_sun_awt_font_NativeFontWrapper_registerFonts+0x14C0
Library=E:\temp\I1107227956\Windows\resource\jre\jre\bin\fontmanager.dll
Current Java thread:
at sun.awt.font.NativeFontWrapper.registerFonts(Native Method)
- locked <0x1c68c558>(a java.lang.Class)
at
sun.java2d.SunGraphicsEnvironment.addPathFonts(SunGraphicsEnvironment.java:797)
at
sun.java2d.SunGraphicsEnvironment.registerFonts(SunGraphicsEnvironment.java:640)
at
sun.java2d.SunGraphicsEnvironment.access$200(SunGraphicsEnvironment.java:53)
at sun.java2d.SunGraphicsEnvironment$2.run(SunGraphicsEnvironment.java:262)
at java.security.AccessController.doPrivileged(Native Method)
at
sun.java2d.SunGraphicsEnvironment.loadFonts(SunGraphicsEnvironment.java:256)
- locked <0x10241d98>(a sun.awt.Win32GraphicsEnvironment)
at
sun.java2d.SunGraphicsEnvironment.mapFontName(SunGraphicsEnvironment.java:504)
at java.awt.Font.initializeFont(Font.java:312)
at java.awt.Font.<init>(Font.java:344)
at
sun.awt.windows.WDesktopProperties.setFontProperty(WDesktopProperties.java:157)
- locked <0x100373a0>(a sun.awt.windows.WDesktopProperties)
at sun.awt.windows.WDesktopProperties.getWindowsParameters(Native Method)
at sun.awt.windows.WDesktopProperties.<init>(WDesktopProperties.java:56)
at sun.awt.windows.WToolkit.initializeDesktopProperties(WToolkit.java:876)
at java.awt.Toolkit.getDesktopProperty(Toolkit.java:1569)
- locked <0x1001f850>(a sun.awt.windows.WToolkit)
at com.sun.java.swing.plaf.windows.XPStyle.getXP(XPStyle.java:75)
- locked <0x1c74c6b8>(a java.lang.Class)
at
com.sun.java.swing.plaf.windows.WindowsTreeUI$ExpandedIcon.<init>(WindowsTreeUI.java:123)
at
com.sun.java.swing.plaf.windows.WindowsTreeUI$ExpandedIcon.createExpandedIcon(WindowsTreeUI.java:127)
at
com.sun.java.swing.plaf.windows.WindowsLookAndFeel.initComponentDefaults(WindowsLookAndFeel.java:309)
at
javax.swing.plaf.basic.BasicLookAndFeel.getDefaults(BasicLookAndFeel.java:81)
at javax.swing.UIManager.setLookAndFeel(UIManager.java:394)
at javax.swing.UIManager.setLookAndFeel(UIManager.java:424)
at ZeroGad.a(DashoA8113)
- locked <0x1c5ef3e0>(a java.lang.Class)
at ZeroGq.b(DashoA8113)
at ZeroGq.a(DashoA8113)
at ZeroGq.a(DashoA8113)
at com.zerog.ia.installer.LifeCycleManager.b(DashoA8113)
at com.zerog.ia.installer.LifeCycleManager.a(DashoA8113)
at com.zerog.ia.installer.Main.main(DashoA8113)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:324)
at com.zerog.lax.LAX.launch(DashoA8113)
at com.zerog.lax.LAX.main(DashoA8113)
Dynamic libraries:
0x00400000 - 0x00407000
E:\temp\I1107227956\Windows\resource\jre\bin\javaw.exe
0x7C900000 - 0x7C9B0000 C:\WINDOWS\system32\ntdll.dll
0x7C800000 - 0x7C8F4000 C:\WINDOWS\system32\kernel32.dll
0x77DD0000 - 0x77E6B000 C:\WINDOWS\system32\ADVAPI32.dll
0x77E70000 - 0x77F01000 C:\WINDOWS\system32\RPCRT4.dll
0x77D40000 - 0x77DD0000 C:\WINDOWS\system32\USER32.dll
0x77F10000 - 0x77F56000 C:\WINDOWS\system32\GDI32.dll
0x77C10000 - 0x77C68000 C:\WINDOWS\system32\MSVCRT.dll
0x08000000 - 0x08138000
E:\temp\I1107227956\Windows\resource\jre\jre\bin\client\jvm.dll
0x76B40000 - 0x76B6D000 C:\WINDOWS\system32\WINMM.dll
0x10000000 - 0x10007000
E:\temp\I1107227956\Windows\resource\jre\jre\bin\hpi.dll
0x00830000 - 0x0083E000
E:\temp\I1107227956\Windows\resource\jre\jre\bin\verify.dll
0x00840000 - 0x00859000
E:\temp\I1107227956\Windows\resource\jre\jre\bin\java.dll
0x00860000 - 0x0086D000
E:\temp\I1107227956\Windows\resource\jre\jre\bin\zip.dll
0x02F30000 - 0x0303F000
E:\temp\I1107227956\Windows\resource\jre\jre\bin\awt.dll
0x73000000 - 0x73026000 C:\WINDOWS\system32\WINSPOOL.DRV
0x76390000 - 0x763AD000 C:\WINDOWS\system32\IMM32.dll
0x774E0000 - 0x7761C000 C:\WINDOWS\system32\ole32.dll
0x03040000 - 0x03090000
E:\temp\I1107227956\Windows\resource\jre\jre\bin\fontmanager.dll
0x73760000 - 0x737A9000 C:\WINDOWS\system32\ddraw.dll
0x73BC0000 - 0x73BC6000 C:\WINDOWS\system32\DCIMAN32.dll
0x73940000 - 0x73A10000 C:\WINDOWS\system32\D3DIM700.DLL
0x03660000 - 0x03666000 C:\DOCUME~1\DAN~1.GBA\LOCALS~1\TempIadHide3.dll
0x74720000 - 0x7476B000 C:\WINDOWS\system32\MSCTF.dll
0x605D0000 - 0x605D9000 C:\WINDOWS\system32\mslbui.dll
0x76C90000 - 0x76CB8000 C:\WINDOWS\system32\imagehlp.dll
0x59A60000 - 0x59B01000 C:\WINDOWS\system32\DBGHELP.dll
0x77C00000 - 0x77C08000 C:\WINDOWS\system32\VERSION.dll
0x76BF0000 - 0x76BFB000 C:\WINDOWS\system32\PSAPI.DLL
Heap at VM Abort:
Heap
def new generation total 2304K, used 629K [0x10010000, 0x10280000,
0x10f20000)
eden space 2112K, 20% used [0x10010000, 0x1007d630, 0x10220000)
from space 192K, 100% used [0x10220000, 0x10250000, 0x10250000)
to space 192K, 0% used [0x10250000, 0x10250000, 0x10280000)
tenured generation total 30272K, used 577K [0x10f20000, 0x12cb0000,
0x1c410000)
the space 30272K, 1% used [0x10f20000, 0x10fb07e8, 0x10fb0800,
0x12cb0000)
compacting perm gen total 4096K, used 3337K [0x1c410000, 0x1c810000,
0x20410000)
the space 4096K, 81% used [0x1c410000, 0x1c752480, 0x1c752600,
0x1c810000)
Local Time = Mon Jan 31 21:44:31 2005
Elapsed Time = 2
#
# The exception above was detected in native code outside the VM
#
# Java VM: Java HotSpot(TM) Client VM (1.4.2_04-b05 mixed mode)
#
 

Re:Installation error

. wrote:
Quote
Howdy:

When I try to install the foundation edition, the installer unpacks all the
files and then bombs with a Visual C++ error and dumps a file with the
following in it. Any help?


Exactly what operating system are you using?
Have you reviewed the installation support page?
support.borland.com/install/default.asp
--
Regards,
Lori Olson [TeamB]
------------
Save yourself, and everyone else, some time and search the
newsgroups and the FAQ-O-Matic before posting your next
question.
Google Advanced Newsgroup Search
www.google.ca/advanced_group_search
Other Newsgroup Searches:
www.borland.com/newsgroups/ngsearch.html
Joi Ellis's FAQ-O-Matic:
www.visi.com/~gyles19/fom-serve/cache/1.html
 

Re:Installation error

I get a similar error.
I had, in fact, installed jbuilder foundation, successfully I thought, but
the help system didn't work.
So I un-installed it with the intention of re-installing it, making sure
that I ticked any 'instal help' options that were available.
However I now get the error when I try to re-install.
I'm running win98
Stuart
"Lori M Olson [TeamB]" < XXXX@XXXXX.COM >wrote in message
Quote
. wrote:

>Howdy:
>
>When I try to install the foundation edition, the installer unpacks all
the
>files and then bombs with a Visual C++ error and dumps a file with the
>following in it. Any help?
>
>

Exactly what operating system are you using?

Have you reviewed the installation support page?

support.borland.com/install/default.asp

--

Regards,

Lori Olson [TeamB]

------------

Save yourself, and everyone else, some time and search the
newsgroups and the FAQ-O-Matic before posting your next
question.

Google Advanced Newsgroup Search
www.google.ca/advanced_group_search
Other Newsgroup Searches:
www.borland.com/newsgroups/ngsearch.html
Joi Ellis's FAQ-O-Matic:
www.visi.com/~gyles19/fom-serve/cache/1.html
 

Re:Installation error

On 3/17/2005 at 10:17:21 AM, Stuart Allen wrote:
Quote
I get a similar error. I had, in fact, installed jbuilder foundation,
successfully I thought, but the help system didn't work.
The help files are a separate download.
--
Regards,
John McGrath [TeamB]
---------------------------------------------------
Before sending me e-mail, please read:
www.JPMcGrath.net/newsgroups/e-mail.html
 

Re:Installation error

Thanks for this information. However, I can't find the help file/files to
download. There are plenty for "paid-for" jbuilder, but I can't find the
ones I need for foundation.
By the way, the reason my re-install failed was that I had downloaded the
wrong version i.e. not the windows version. Silly me.
Stuart
"John McGrath [TeamB]" < XXXX@XXXXX.COM >wrote in message
Quote
On 3/17/2005 at 10:17:21 AM, Stuart Allen wrote:

>I get a similar error. I had, in fact, installed jbuilder foundation,
>successfully I thought, but the help system didn't work.

The help files are a separate download.

--
Regards,

John McGrath [TeamB]

---------------------------------------------------
Before sending me e-mail, please read:
www.JPMcGrath.net/newsgroups/e-mail.html
 

Re:Installation error

Stuart Allen wrote:
Quote
Thanks for this information. However, I can't find the help file/files to
download. There are plenty for "paid-for" jbuilder, but I can't find the
ones I need for foundation.

By the way, the reason my re-install failed was that I had downloaded the
wrong version i.e. not the windows version. Silly me.

Stuart

Go back to the page on which you found the link to download Foundation.
ALL the links for ALL the samples, extras, and help files are on that
page.
--
Regards,
Lori Olson [TeamB]
------------
Save yourself, and everyone else, some time and search the
newsgroups and the FAQ-O-Matic before posting your next
question.
Google Advanced Newsgroup Search
www.google.ca/advanced_group_search
Other Newsgroup Searches:
www.borland.com/newsgroups/ngsearch.html
Joi Ellis's FAQ-O-Matic:
www.visi.com/~gyles19/fom-serve/cache/1.html
 

Re:Installation error

When I install the CodeWright ver 7.5, I encounter the error message that "Setup has detected that uninstallShield is in use, pls close the uninstallShield and restart setup"
 

Re:Installation error

Quote
When I install the CodeWright ver 7.5, I encounter the error message that "Setup has detected that uninstallShield is in use, pls close the uninstallShield and restart setup"
IMHO this has nothing to do with CodeWright itself. Usually You'll
encounter this type of Warning if trying to install a "InstallShield"
made setup without having administrative rights.
You may use "MachMichAdmin" batch from c't magazine to easily
manage such problems in the future. "MachMichAdmin" is German
for "MakeMeAdministrator" or "RaiseMyRights", thus, in the foreign
pages of c't / heise magazine it could have another name.
German version is here: www.heise.de/ct/ftp/05/23/112/
Mai K. R.
--
und wech...
 

Re:Installation error

Have you tried rebooting? Have you tried turning off your Virus protection? Are you installing 7.5.5?
RK
< XXXX@XXXXX.COM >wrote:
Quote

When I install the CodeWright ver 7.5, I encounter the error message that "Setup has detected that uninstallShield is in use, pls close the uninstallShield and restart setup"
 

Re:Installation error

Yes, I did reboot the system and the Software version is 7.5.
Patrick
"RK" < XXXX@XXXXX.COM >wrote:
Quote

Have you tried rebooting? Have you tried turning off your Virus protection? Are you installing 7.5.5?

RK



< XXXX@XXXXX.COM >wrote:
>
>When I install the CodeWright ver 7.5, I encounter the error message that "Setup has detected that uninstallShield is in use, pls close the uninstallShield and restart setup"