Board index » jbuilder » Project, Classes...nothing displaying!

Project, Classes...nothing displaying!


2004-07-07 03:56:50 AM
jbuilder8
Hi Everyone,
so, I'm pretty new to Jbuilder, but have been going along just fine until now. I started a project, know the toolset pretty well, everything is compiling....good stuff.
Recently I was working on some thing with Jbuilder and it appeared to freeze up...so I needed to kill it. Next time I started it up, my project would not appear....odd I thought so I went to open it manually, but when I tried to open my project...I get a 'java.lang.NullPointerException' in the status bar....the only thing I can see is the main window with menu, tool bar and status bar.....
Has this happened to anyone else? All of the source, class and project files are intact. I have changed nothing with my java environment. Could a file be corrupt somewhere?
Puzzled....can anyone help? Many many thanks from a Jbuilder novice.
 
 

Re:Project, Classes...nothing displaying!

DrSmartman wrote:
Quote
Hi Everyone,

so, I'm pretty new to Jbuilder, but have been going along just fine until now. I started a project, know the toolset pretty well, everything is compiling....good stuff.

Recently I was working on some thing with Jbuilder and it appeared to freeze up...so I needed to kill it. Next time I started it up, my project would not appear....odd I thought so I went to open it manually, but when I tried to open my project...I get a 'java.lang.NullPointerException' in the status bar....the only thing I can see is the main window with menu, tool bar and status bar.....

Has this happened to anyone else? All of the source, class and project files are intact. I have changed nothing with my java environment. Could a file be corrupt somewhere?

Puzzled....can anyone help? Many many thanks from a Jbuilder novice.
I'm not a Mac user, but this sounds like the old messed-up workspace
problem.
In Windows, you fix this by going to the
<user-home>/.jbuilderX/workspaces directory and deleting the files in
there. Hopefully you can translate that into Mac'ish.
--
Regards,
Lori Olson [TeamB]
------------
Save yourself, and everyone else, some time and search the
newsgroups and the FAQ-O-Matic before posting your next
question.
Google Advanced Newsgroup Search
www.google.ca/advanced_group_search
Other Newsgroup Searches:
www.borland.com/newsgroups/ngsearch.html
Joi Ellis's FAQ-O-Matic:
www.visi.com/~gyles19/fom-serve/cache/1.html
 

Re:Project, Classes...nothing displaying!

Hello....thanks for the response! Well, your analysis sounds right on...the workspace certainly doesn't work! relieved to hear it is a "known issue". Unfortunately, I couldn't find a 'workspace' directory under JBuilder or the project i am using (or my entire disk for that matter!). I even tried recreating the 'workspace' directory with full permissions directly under 'JBuilderX' directory....didn't work.
Any other suggestions? I'd assume the same directory structure for Mac OS X and Windows installation.....Thanks and keep 'em coming!
"Lori M Olson [TeamB]" < XXXX@XXXXX.COM >wrote:
Quote
DrSmartman wrote:
>Hi Everyone,
>
>so, I'm pretty new to Jbuilder, but have been going along just fine until now. I started a project, know the toolset pretty well, everything is compiling....good stuff.
>
>Recently I was working on some thing with Jbuilder and it appeared to freeze up...so I needed to kill it. Next time I started it up, my project would not appear....odd I thought so I went to open it manually, but when I tried to open my project...I get a 'java.lang.NullPointerException' in the status bar....the only thing I can see is the main window with menu, tool bar and status bar.....
>
>Has this happened to anyone else? All of the source, class and project files are intact. I have changed nothing with my java environment. Could a file be corrupt somewhere?
>
>Puzzled....can anyone help? Many many thanks from a Jbuilder novice.

I'm not a Mac user, but this sounds like the old messed-up workspace
problem.

In Windows, you fix this by going to the
<user-home>/.jbuilderX/workspaces directory and deleting the files in
there. Hopefully you can translate that into Mac'ish.

--

Regards,

Lori Olson [TeamB]

------------

Save yourself, and everyone else, some time and search the
newsgroups and the FAQ-O-Matic before posting your next
question.

Google Advanced Newsgroup Search
www.google.ca/advanced_group_search
Other Newsgroup Searches:
www.borland.com/newsgroups/ngsearch.html
Joi Ellis's FAQ-O-Matic:
www.visi.com/~gyles19/fom-serve/cache/1.html

 

{smallsort}

Re:Project, Classes...nothing displaying!

DrSmartman wrote:
Quote
Hello....thanks for the response! Well, your analysis sounds right
on...the workspace certainly doesn't work! relieved to hear it is a
"known issue". Unfortunately, I couldn't find a 'workspace' directory
under JBuilder or the project i am using (or my entire disk for that
matter!). I even tried recreating the 'workspace' directory with full
permissions directly under 'JBuilderX' directory....didn't work.

Any other suggestions? I'd assume the same directory structure for
Mac OS X and Windows installation.....Thanks and keep 'em coming!

Ok, maybe I wasn't clear enough the first time.
Not a project directory.
Not the JBuilder install directory.
You have to start in your "HOME" directory, where ever that is on a Mac.
From there you need the ".jbuilderX" directory. And then under it you
will find the "workspace" directory.
Surely Mac's have some way of searching the hard drive for a directory
of the name "workspace"?
--
Regards,
Lori Olson [TeamB]
 

Re:Project, Classes...nothing displaying!

My Bad!!!! I was in the wrong directory. This seems to have fixed my little issues.
Thanks a lot Lori!!!!!
"Lori M Olson [TeamB]" < XXXX@XXXXX.COM >wrote:
Quote
DrSmartman wrote:
>Hi Everyone,
>
>so, I'm pretty new to Jbuilder, but have been going along just fine until now. I started a project, know the toolset pretty well, everything is compiling....good stuff.
>
>Recently I was working on some thing with Jbuilder and it appeared to freeze up...so I needed to kill it. Next time I started it up, my project would not appear....odd I thought so I went to open it manually, but when I tried to open my project...I get a 'java.lang.NullPointerException' in the status bar....the only thing I can see is the main window with menu, tool bar and status bar.....
>
>Has this happened to anyone else? All of the source, class and project files are intact. I have changed nothing with my java environment. Could a file be corrupt somewhere?
>
>Puzzled....can anyone help? Many many thanks from a Jbuilder novice.

I'm not a Mac user, but this sounds like the old messed-up workspace
problem.

In Windows, you fix this by going to the
<user-home>/.jbuilderX/workspaces directory and deleting the files in
there. Hopefully you can translate that into Mac'ish.

--

Regards,

Lori Olson [TeamB]

------------

Save yourself, and everyone else, some time and search the
newsgroups and the FAQ-O-Matic before posting your next
question.

Google Advanced Newsgroup Search
www.google.ca/advanced_group_search
Other Newsgroup Searches:
www.borland.com/newsgroups/ngsearch.html
Joi Ellis's FAQ-O-Matic:
www.visi.com/~gyles19/fom-serve/cache/1.html