Board index » jbuilder » Problem with properties file

Problem with properties file


2005-01-18 10:05:55 PM
jbuilder19
Hello,
I am developing a web application. I need to put 2 properties file in
the WEB-INF\classes folder. I create and
edit these files from within JBuilder but when I compile the project to
create the war file all my properties file
are deleted and the war file doesn't contain the properties file.
How can I do in these case?
Thank you for the suggestion and regards,
Sandro
 
 

Re:Problem with properties file

"Sandro Germani" < XXXX@XXXXX.COM >wrote in message
Quote
Hello,

I am developing a web application. I need to put 2 properties file in
the WEB-INF\classes folder. I create and
edit these files from within JBuilder but when I compile the project to
create the war file all my properties file
are deleted and the war file doesn't contain the properties file.
How can I do in these case?

Thank you for the suggestion and regards,
Sandro

This happend normally when you do a rebuild. Try doing make without rebuild
and see if the deployment is correct.
 

Re:Problem with properties file

You have to create the properties files in your source tree, not directly in
WEB-INF/classes. The properties files will be copied over to your web
application automatically (check the "Content" pane of the Web Application
Properties dialog to make sure that "Properties file" is in the list).
--
Kevin Dean [TeamB]
Dolphin Data Development Ltd.
www.datadevelopment.com/
Please see Borland's newsgroup guidelines at
info.borland.com/newsgroups/guide.html
"Sandro Germani" < XXXX@XXXXX.COM >wrote in message
Quote
Hello,

I am developing a web application. I need to put 2 properties file in
the WEB-INF\classes folder. I create and
edit these files from within JBuilder but when I compile the project to
create the war file all my properties file
are deleted and the war file doesn't contain the properties file.
How can I do in these case?

Thank you for the suggestion and regards,
Sandro

 

{smallsort}

Re:Problem with properties file

Paul Nichols (TeamB) wrote:
Quote
I still have problems with this (correct info, BTW), when doing a
Rebuild, rather than a make.
That's strange. I've never had that problem with a web application.
--
Kevin Dean [TeamB]
Dolphin Data Development Ltd.
www.datadevelopment.com/
Please see Borland's newsgroup guidelines at
info.borland.com/newsgroups/guide.html
 

Re:Problem with properties file

Kevin Dean [TeamB] wrote:
Quote
Paul Nichols (TeamB) wrote:


>I still have problems with this (correct info, BTW), when doing a
>Rebuild, rather than a make.


That's strange. I've never had that problem with a web application.

Ok, enough with the cross posting. Followups set to the .ide group
--
Regards,
Lori Olson [TeamB]
------------
Save yourself, and everyone else, some time and search the
newsgroups and the FAQ-O-Matic before posting your next
question.
Google Advanced Newsgroup Search
www.google.ca/advanced_group_search
Other Newsgroup Searches:
www.borland.com/newsgroups/ngsearch.html
Joi Ellis's FAQ-O-Matic:
www.visi.com/~gyles19/fom-serve/cache/1.html
 

Re:Problem with properties file

"Kevin Dean [TeamB]" < XXXX@XXXXX.COM >wrote in message
Quote
You have to create the properties files in your source tree, not directly
in
I still have problems with this (correct info, BTW), when doing a Rebuild,
rather than a make.
 

Re:Problem with properties file

Sandro Germani a écrit :
Quote
Hello,

I am developing a web application. I need to put 2 properties file in
the WEB-INF\classes folder. I create and
edit these files from within JBuilder but when I compile the project to
create the war file all my properties file
are deleted and the war file doesn't contain the properties file.
How can I do in these case?

Thank you for the suggestion and regards,
Sandro

Hi,
I developed an application which uses '.properties' file as
PropertyResourceBundle
(javax.swing.UIDefaults.addResourceBundle("my.resource.bundle")).
I use Wizard to create a Native Executive. When I unjar the generated
'myapplication.jar' file, I can find the properties files. But when I
run the 'myapplication.exe' file, my program does not find them (or take
them into account). The problem occurs also with a 'castor.properties'
file while I used the JBuilder XML Wizard.
Of course, my application runs correctly in my IDE.
I use JBuilder 9 Developer version.
I posted here because it could be the same problem.
Does anyone meet the same difficulties ?
Thank you for your help.
With regards,
Charly