Board index » jbuilder » portlet.xml

portlet.xml


2005-03-17 04:49:47 PM
jbuilder15
Hi all,
I'm new to JBuilder and I don't know if this is the appropriate newsgroup.
If I'm wrong please address me to the right place.
I'm using JBuilder2005 (Update 1) and I'm trying to create a web module for
a portlet server using the wizard "JSR168 Portlet wizard" . The wizard
generates some files. One of these is the "portlet.xml" file. If I try to
validate it I received this error:
SchemaLocation: schemaLocation value =
'java.sun.com/xml/ns/portlet/portlet-app_1_0.xsd' must have even
number of URIs.
I know that the problem is solved setting value as:
value = 'java.sun.com/xml/ns/portlet/portlet-app_1_0.xsd
java.sun.com/xml/ns/portlet/portlet-app_1_0.xsd'
(as specified also in an Xdoclet bug issue)
My question: How JBuilder creates the "portlet.xml" file? Does it use some
template? How can I solve this bug?
Thanks,
aris
 
 

Re:portlet.xml

Stefano Masiero wrote:
Quote
Hi all,
I'm new to JBuilder and I don't know if this is the appropriate newsgroup.
If I'm wrong please address me to the right place.

I'm using JBuilder2005 (Update 1) and I'm trying to create a web module for
a portlet server using the wizard "JSR168 Portlet wizard" . The wizard
generates some files. One of these is the "portlet.xml" file. If I try to
validate it I received this error:

SchemaLocation: schemaLocation value =
'java.sun.com/xml/ns/portlet/portlet-app_1_0.xsd' must have even
number of URIs.

I know that the problem is solved setting value as:

value = 'java.sun.com/xml/ns/portlet/portlet-app_1_0.xsd
java.sun.com/xml/ns/portlet/portlet-app_1_0.xsd'

(as specified also in an Xdoclet bug issue)

My question: How JBuilder creates the "portlet.xml" file? Does it use some
template? How can I solve this bug?

Thanks,
aris


Looks like a bug. I did a quick search on the Update 4 notes and there
are no references to portlets, so this is unlikely to be fixed in Update
4 (you could still try, sometimes these things don't get documented).
Otherwise, file a bug on Quality Central (Tools | Quality Central or
qc.borland.com).
AFAIK, Wizards are used to generate files in a "one-shot" sort of
manner. Unless something else keeps regenerating this file, you should
be able to manually correct the portlet.xml file and continue with no
problems.
--
Regards,
Lori Olson [TeamB]
------------
Save yourself, and everyone else, some time and search the
newsgroups and the FAQ-O-Matic before posting your next
question.
Google Advanced Newsgroup Search
www.google.ca/advanced_group_search
Other Newsgroup Searches:
www.borland.com/newsgroups/ngsearch.html
Joi Ellis's FAQ-O-Matic:
www.visi.com/~gyles19/fom-serve/cache/1.html
 

Re:portlet.xml

Hi Lori,
I'm waiting to install Update4 because I've read on other newsgroups that it
could introduce some problems.
This is the reason why I asked how JBuilder do those files.
I know that the wizard is used "one-shot" and the bug can be fixed manually
(this is what I'm doing now) but I'd like to solve the problem in an
automated way e.g. modifying a template or updating a jar.
I'll try to file the bug (it's my first bug file!!!!! :)).
Thank you for your prompt reply.
aris.
"Lori M Olson [TeamB]" < XXXX@XXXXX.COM >wrote in message
Quote
Stefano Masiero wrote:

>Hi all,
>I'm new to JBuilder and I don't know if this is the appropriate
newsgroup.
>If I'm wrong please address me to the right place.
>
>I'm using JBuilder2005 (Update 1) and I'm trying to create a web module
for
>a portlet server using the wizard "JSR168 Portlet wizard" . The wizard
>generates some files. One of these is the "portlet.xml" file. If I try
to
>validate it I received this error:
>
>SchemaLocation: schemaLocation value =
>'java.sun.com/xml/ns/portlet/portlet-app_1_0.xsd' must have even
>number of URIs.
>
>I know that the problem is solved setting value as:
>
>value = 'java.sun.com/xml/ns/portlet/portlet-app_1_0.xsd
>java.sun.com/xml/ns/portlet/portlet-app_1_0.xsd'
>
>(as specified also in an Xdoclet bug issue)
>
>My question: How JBuilder creates the "portlet.xml" file? Does it use
some
>template? How can I solve this bug?
>
>Thanks,
>aris
>
>

Looks like a bug. I did a quick search on the Update 4 notes and there
are no references to portlets, so this is unlikely to be fixed in Update
4 (you could still try, sometimes these things don't get documented).

Otherwise, file a bug on Quality Central (Tools | Quality Central or
qc.borland.com).

AFAIK, Wizards are used to generate files in a "one-shot" sort of
manner. Unless something else keeps regenerating this file, you should
be able to manually correct the portlet.xml file and continue with no
problems.

--

Regards,

Lori Olson [TeamB]

------------

Save yourself, and everyone else, some time and search the
newsgroups and the FAQ-O-Matic before posting your next
question.

Google Advanced Newsgroup Search
www.google.ca/advanced_group_search
Other Newsgroup Searches:
www.borland.com/newsgroups/ngsearch.html
Joi Ellis's FAQ-O-Matic:
www.visi.com/~gyles19/fom-serve/cache/1.html
 

{smallsort}