Board index » jbuilder » JBuilderX and J2SE 1.5.0

JBuilderX and J2SE 1.5.0


2004-10-04 11:34:21 PM
jbuilder7
Are there any known issues for running JBuilderX Foundation on Sun's
recently released J2SE 1.5.0?
Heinz Wehner
(Karlsruhe, Germany)
 
 

Re:JBuilderX and J2SE 1.5.0

Quote
Are there any known issues for running JBuilderX Foundation on Sun's
recently released J2SE 1.5.0?

Heinz Wehner
(Karlsruhe, Germany)
It won't work.
Use JBuilder 2005.
 

Re:JBuilderX and J2SE 1.5.0

Thanks. It's a pity but it seems to be consistent with Borlands
versioning policy. BTW, JBuilderX Foundation runs fine on the latest
JDK 1.4.2 over here while officially, only JDK 1.4.1 is recommended.
Heinz Wehner
(Karlsruhe, Germany)
On Tue, 5 Oct 2004 01:16:41 +0800,
"Vincent Cantin" < XXXX@XXXXX.COM >wrote:
Quote
>Are there any known issues for running JBuilderX Foundation on Sun's
>recently released J2SE 1.5.0?
>
>Heinz Wehner
>(Karlsruhe, Germany)

It won't work.
Use JBuilder 2005.
 

{smallsort}

Re:JBuilderX and J2SE 1.5.0

Wow. It won't work with 1.5?
I anticipated that I might be told that it was not officially supported but didn't think that JBuilderX would be completely unable to work with 1.5 :(
This is a worry for me... I have purchased 2005 Developer and will be sharing files with users who still use JbuilderX. Does this also mean that I can not use 1.5 now? (i.e. if I build a project with 1.5, can someone using JbuilderX open my project? I'm suspecting that it would not compile, espessially if I use 1.5 features)
Are there any other Gotchas that I need to be aware of regarding 2005 vs X ?
Thanks,
Andy
Heinz Wehner < XXXX@XXXXX.COM >wrote:
Quote
Thanks. It's a pity but it seems to be consistent with Borlands
versioning policy. BTW, JBuilderX Foundation runs fine on the latest
JDK 1.4.2 over here while officially, only JDK 1.4.1 is recommended.

Heinz Wehner
(Karlsruhe, Germany)


On Tue, 5 Oct 2004 01:16:41 +0800,
"Vincent Cantin" < XXXX@XXXXX.COM >wrote:

>>Are there any known issues for running JBuilderX Foundation on Sun's
>>recently released J2SE 1.5.0?
>>
>>Heinz Wehner
>>(Karlsruhe, Germany)
>
>It won't work.
>Use JBuilder 2005.
 

Re:JBuilderX and J2SE 1.5.0

Quote
Wow. It won't work with 1.5?

I anticipated that I might be told that it was not officially supported
but didn't think that JBuilderX would be completely unable to work with 1.5
:(
Let's say that it won't work "Correctly" with the new features of java 1.5
 

Re:JBuilderX and J2SE 1.5.0

So I could use 1.5 within JBuilderX as long as I only used 1.4 compatable APIs ? That sounds reasonable.
How about my bigger question about mixing development between JBuilderX and 2005? Will there be issues opening projects in one version created in the other?
"Vincent Cantin" < XXXX@XXXXX.COM >wrote:
Quote
>Wow. It won't work with 1.5?
>
>I anticipated that I might be told that it was not officially supported
but didn't think that JBuilderX would be completely unable to work with 1.5
:(

Let's say that it won't work "Correctly" with the new features of java 1.5