Board index » jbuilder » source and debug out of sync

source and debug out of sync


2007-04-21 12:46:25 AM
jbuilder12
Hello
I am getting this message when I run the de{*word*81} even after a fresh
clean/rebuild. Can someone explain and help to resolve? tia.
 
 

Re:source and debug out of sync

Hello
I am not getting the below for a project that worked perfectly
yesterday. For me it is unfathomable. I made no changes and what
worked yesterday is not working now. Since then I have copied over a
new distribution of TC5.0.28, added the xerces api jars, added ant1.6
and still getting this error. The project compiles fine, it is, as
shown below, on the TC startup. How can this be? Has anyone has
similar problems? tia.
Starting Servlet Engine: Apache Tomcat/5.0.28
XML validation disabled
java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:324)
at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:287)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:425)
Caused by: javax.xml.parsers.FactoryConfigurationError: Provider
org.apache.xerces.jaxp.DocumentBuilderFactoryImpl not found
cpanon wrote:
Quote
Hello
I am getting this message when I run the de{*word*81} even after a fresh
clean/rebuild. Can someone explain and help to resolve? tia.
 

Re:source and debug out of sync

cpanon wrote:
Quote
Hello
I am not getting the below for a project that worked perfectly
yesterday. For me it is unfathomable. I made no changes and what
worked yesterday is not working now. Since then I have copied over a
new distribution of TC5.0.28, added the xerces api jars, added ant1.6
and still getting this error. The project compiles fine, it is, as
shown below, on the TC startup. How can this be? Has anyone has
similar problems? tia.

Starting Servlet Engine: Apache Tomcat/5.0.28
XML validation disabled
java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

at java.lang.reflect.Method.invoke(Method.java:324)
at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:287)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:425)
Caused by: javax.xml.parsers.FactoryConfigurationError: Provider
org.apache.xerces.jaxp.DocumentBuilderFactoryImpl not found

cpanon wrote:
>Hello
>I am getting this message when I run the de{*word*81} even after a fresh
>clean/rebuild. Can someone explain and help to resolve? tia.
Where did you "add the xerces api jars"? To the TC server
configuration? Or to your project? Or both?
--
Regards,
Lori Olson [TeamB]
------------
Save yourself, and everyone else, some time and search the
newsgroups and the FAQ-O-Matic before posting your next
question.
Google Advanced Newsgroup Search
www.google.ca/advanced_group_search
Other Newsgroup Searches:
www.borland.com/newsgroups/ngsearch.html
Joi Ellis's FAQ-O-Matic:
www.visi.com/~gyles19/fom-serve/cache/1.html
 

{smallsort}

Re:source and debug out of sync

Hi Lori
Thanks. I guess when it get this inscrutable to just look for
"unnatural causes". It turned out that there was "something" wrong with
that location. I copied the entire project to another location on the
same workstation's hd and it compiled with no problem. Yes, I know I
NEVER has such a problem before fixed by an even more unbelievable. I
know it sounds like I added something or changed something after the
copy, but I am disciplined enough not to do that in a testing mode.
Anyways, it is here for someone else.
Lori M Olson [TeamB] wrote:
Quote
cpanon wrote:
>Hello
>I am not getting the below for a project that worked perfectly
>yesterday. For me it is unfathomable. I made no changes and what
>worked yesterday is not working now. Since then I have copied over a
>new distribution of TC5.0.28, added the xerces api jars, added ant1.6
>and still getting this error. The project compiles fine, it is, as
>shown below, on the TC startup. How can this be? Has anyone has
>similar problems? tia.
>
>Starting Servlet Engine: Apache Tomcat/5.0.28
>XML validation disabled
>java.lang.reflect.InvocationTargetException
>at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>at
>sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>
>at
>sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>
>at java.lang.reflect.Method.invoke(Method.java:324)
>at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:287)
>at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:425)
>Caused by: javax.xml.parsers.FactoryConfigurationError: Provider
>org.apache.xerces.jaxp.DocumentBuilderFactoryImpl not found
>
>cpanon wrote:
>>Hello
>>I am getting this message when I run the de{*word*81} even after a fresh
>>clean/rebuild. Can someone explain and help to resolve? tia.

Where did you "add the xerces api jars"? To the TC server
configuration? Or to your project? Or both?

 

Re:source and debug out of sync

cpanon wrote:
Quote
Hi Lori
Thanks. I guess when it get this inscrutable to just look for
"unnatural causes". It turned out that there was "something" wrong with
that location. I copied the entire project to another location on the
same workstation's hd and it compiled with no problem. Yes, I know I
NEVER has such a problem before fixed by an even more unbelievable. I
know it sounds like I added something or changed something after the
copy, but I am disciplined enough not to do that in a testing mode.
Anyways, it is here for someone else.
Hey, I know how you feel. I really hate problems like that. Thanks for
posting back.
--
Regards,
Lori Olson [TeamB]
------------
Save yourself, and everyone else, some time and search the
newsgroups and the FAQ-O-Matic before posting your next
question.
Google Advanced Newsgroup Search
www.google.ca/advanced_group_search
Other Newsgroup Searches:
www.borland.com/newsgroups/ngsearch.html
Joi Ellis's FAQ-O-Matic:
www.visi.com/~gyles19/fom-serve/cache/1.html