Board index » jbuilder » EJB examples in JBuilder9

EJB examples in JBuilder9


2004-04-07 01:13:36 AM
jbuilder15
I am working on creating session beans and entity beans. I got this
example from "EJB Development Using Borland JBuilder 8 and Borland
Enterprise Server 5.2". I could not find any example code that dealt
with JBuilder9. I create the session bean and all is fine. My problem
arises with entity beans. I create an EJB 2.0 entity bean and link to
a previous database. These are the setting:
Driver: oracle.jdbc.driver.OracleDriver
URL: jdbc:oracle:thin:@10.102.0.81:1521:DEVEL
the username and password are populated.
Database name: DEVEL
JNDI name: DataSource
I have also tried to use this URL:
jdbc:borland:dslocal:C:\eprocess\member.jds
I go through the steps in the article for deploying the jar file and
setting up the server. These are the errors that arrise:
-- Initializing bean access.
-- Succeeded initializing bean access through Home interface.
-- Execution time: 1422 ms.
-- Calling ProfileSession create()
I printed out the ProfileSession because I am not sure if this is
where the error startes.
"profileSession returned from profileSessionHome.create in
ProfileSessionTestClient1
Stub[repository_id=RMI:whitepaper.ProfileSession:0000000000000000,key=Servic
eId[service=/EJB[Chuck\/standard]ProfileSession,id={4
bytes:
(0)(0)(0)(0)},key_string=%00PMC%00%00%00%04%00%00%00$/EJB%5bChuck%5c/standar
d%5dProfileSession%00%00%00%00%04%00%00%00%00],codebase=null]"
-- Succeeded: create()
-- Execution time: 109 ms.
-- Return value : Stub[repository_id=RMI:whitepaper.Pr ...
-- Calling getMember(1)
-- Succeeded: getMember(1)
-- Execution time: 141 ms.
-- Return value from getMember(1): NamingException in
ProfileSessionBean ' ...
This code is generated or put in by example, all except for the
database. I can not figure out the problem. Can anyone help??
Chuck
 
 

Re:EJB examples in JBuilder9

chuck keuper wrote:
Quote
I am working on creating session beans and entity beans. I got this
example from "EJB Development Using Borland JBuilder 8 and Borland
Enterprise Server 5.2". I could not find any example code that dealt
with JBuilder9. I create the session bean and all is fine. My problem
arises with entity beans. I create an EJB 2.0 entity bean and link to
a previous database. These are the setting:

Since you are using BES, I would suggest that you ask this question in
one of the BES groups.
support.borland.com/newsgroups/bes.asp
--
Regards,
Lori Olson (TeamB)
------------
Save yourself, and everyone else, some time and search the
newsgroups and the FAQ-O-Matic before posting your next
question.
Google Advanced Newsgroup Search
www.google.ca/advanced_group_search
Other Newsgroup Searches:
www.borland.com/newsgroups/ngsearch.html
Joi Ellis's FAQ-O-Matic:
www.visi.com/~gyles19/fom-serve/cache/1.html