Board index » jbuilder » -Target 1.1 HOW !!!

-Target 1.1 HOW !!!


2004-06-21 09:55:43 PM
jbuilder3
One of the US carriers got a requirement that all classes MUST be compiled
with the parameter "-target 1.1" and right now I'm LOST in how to do that :(
I'm using JBuilder 9 Mobile Edition and under Builder I can select "Java 2
SDK, v 1.2 and later" but not 1.1 and I see no way I can add the parameter
manually.
If anyone got an idea, then PLEASE let me know ASAP.
Cheers,
Sam Nova
 
 

Re:-Target 1.1 HOW !!!

Have you tried selecting JDK 1.1 using "Tools | Configure JDK's..."?
Assuming JBuilder 9 supports JDK 1.1 (I'm not sure if it does) that should
solve your problem, assuming that you're also targeting 1.1 libraries.
--
Check out our latest white papers at
www.datadevelopment.com/papers/index.html
BladeNET Scores With Borland Enterprise Tools
Team Development with JBuilder and Borland Enterprise Server
Dolphin Data Development Ltd.
www.datadevelopment.com/
"Sam Nova" < XXXX@XXXXX.COM >wrote in message
Quote
One of the US carriers got a requirement that all classes MUST be compiled
with the parameter "-target 1.1" and right now I'm LOST in how to do that
:(

I'm using JBuilder 9 Mobile Edition and under Builder I can select "Java 2
SDK, v 1.2 and later" but not 1.1 and I see no way I can add the parameter
manually.

If anyone got an idea, then PLEASE let me know ASAP.

Cheers,

Sam Nova


 

Re:-Target 1.1 HOW !!!

Was just about to reply to it myself :) See below... This also works with
MIDP 2.0
Argh....Guess I should read the help pages twice in the future..
Target VM must be set to "All Java SDKs" and then it is 1.1
As the documentation says:
All Java SDKs Generates the class files to work with versions 1.1 and all
VMs in the Java 2 SDK. When you select this as the target VM, your class
files can be loaded by any VM. If you select this target VM, you need to
enter the following VM Parameter on the Run page of the Runtime
Configurations dialog box in order for the Smart Swap de{*word*81} feature
(JBuilder Developer and Enterprise) to work properly: -Xverify:none
"Kevin Dean" < XXXX@XXXXX.COM >wrote in message
Quote
Have you tried selecting JDK 1.1 using "Tools | Configure JDK's..."?
Assuming JBuilder 9 supports JDK 1.1 (I'm not sure if it does) that should
solve your problem, assuming that you're also targeting 1.1 libraries.

--
Check out our latest white papers at
www.datadevelopment.com/papers/index.html

BladeNET Scores With Borland Enterprise Tools
Team Development with JBuilder and Borland Enterprise Server

Dolphin Data Development Ltd.
www.datadevelopment.com/

"Sam Nova" < XXXX@XXXXX.COM >wrote in message
news:40d6e8d8$ XXXX@XXXXX.COM ...
>One of the US carriers got a requirement that all classes MUST be
compiled
>with the parameter "-target 1.1" and right now I'm LOST in how to do
that
:(
>
>I'm using JBuilder 9 Mobile Edition and under Builder I can select "Java
2
>SDK, v 1.2 and later" but not 1.1 and I see no way I can add the
parameter
>manually.
>
>If anyone got an idea, then PLEASE let me know ASAP.
>
>Cheers,
>
>Sam Nova
>
>


 

{smallsort}