Board index » jbuilder » Layout and Designer problems Jbuilder 8,9,10 to 2005

Layout and Designer problems Jbuilder 8,9,10 to 2005


2005-05-26 03:25:00 PM
jbuilder15
Please help. I have been a Jbuilder user since Version 3.5 Enterprise
with great success. However, designs that work fine in Jbuilder 8,9,10
fall apart when I try to use the UI designer under 2005. I have updated
my 2005 with Update 4.
What has changed that would make my previously written JBuilder
code not work in the UI Designer of the new one. I really need to
understand, even if I have to rewrite some of the code in the JBINIT,
but I'm not even sure whats causing all the problems.
I appreciate any help I could get.
William
 
 

Re:Layout and Designer problems Jbuilder 8,9,10 to 2005

Hello,
Is it possible that someone would at least provide a point of reference
to why this is happening to me.
william wrote:
Quote
Please help. I have been a Jbuilder user since Version 3.5 Enterprise
with great success. However, designs that work fine in Jbuilder 8,9,10
fall apart when I try to use the UI designer under 2005. I have updated
my 2005 with Update 4.

What has changed that would make my previously written JBuilder
code not work in the UI Designer of the new one. I really need to
understand, even if I have to rewrite some of the code in the JBINIT,
but I'm not even sure whats causing all the problems.

I appreciate any help I could get.

William



 

Re:Layout and Designer problems Jbuilder 8,9,10 to 2005

The major change is that JB 2005 uses another backend for managing visualli
designed controls and components on the frame or pane.
It tries to create live instance of almost all components and also all
anonymous classes like actions or data models.
Posible source of problems could be an action class that you have in your
code or model instance.
I will suggest you to try to comment some parts of your code until it
displaysi properly in desinger so after you find the problematic code in
your frame class you will know what to do.
DOychin
"william" < XXXX@XXXXX.COM >wrote in message
Quote
Hello,

Is it possible that someone would at least provide a point of reference to
why this is happening to me.



william wrote:
>Please help. I have been a Jbuilder user since Version 3.5 Enterprise
>with great success. However, designs that work fine in Jbuilder 8,9,10
>fall apart when I try to use the UI designer under 2005. I have updated
>my 2005 with Update 4.
>
>What has changed that would make my previously written JBuilder
>code not work in the UI Designer of the new one. I really need to
>understand, even if I have to rewrite some of the code in the JBINIT, but
>I'm not even sure whats causing all the problems.
>
>I appreciate any help I could get.
>
>William
>
>

 

{smallsort}

Re:Layout and Designer problems Jbuilder 8,9,10 to 2005

william < XXXX@XXXXX.COM >wrote:
Quote
Please help. I have been a Jbuilder user since Version 3.5 Enterprise
with great success. However, designs that work fine in Jbuilder 8,9,10
fall apart when I try to use the UI designer under 2005. I have updated
my 2005 with Update 4.

What has changed that would make my previously written JBuilder
code not work in the UI Designer of the new one. I really need to
understand, even if I have to rewrite some of the code in the JBINIT,
but I'm not even sure whats causing all the problems.

I appreciate any help I could get.

William



well.... it is JB2005 bug.... a big one.... class 5....
 

Re:Layout and Designer problems Jbuilder 8,9,10 to 2005

So what can we do to help get this 'bug' resolved? I have an idea - allow
me to disable the designer's attempt
to create 'live' representations of my components! I'm not sure why, in
design view, that I really need to see lists (etc) populated. I know I've
banged my head up against the wall many times with this sort of issue. Now,
I'm just designing on paper then coding everything in by hand. I'm not sure
that's what the intent was, but that's what I've found to work best.
--
Todd Frahm
Manager - Software Engineering
Digital Telecommunications Inc
---------------------------------------------------
Only one can be first!
"ivan" < XXXX@XXXXX.COM >wrote in message
Quote

william < XXXX@XXXXX.COM >wrote:
>Please help. I have been a Jbuilder user since Version 3.5 Enterprise
>with great success. However, designs that work fine in Jbuilder 8,9,10
>fall apart when I try to use the UI designer under 2005. I have updated
>my 2005 with Update 4.
>
>What has changed that would make my previously written JBuilder
>code not work in the UI Designer of the new one. I really need to
>understand, even if I have to rewrite some of the code in the JBINIT,
>but I'm not even sure whats causing all the problems.
>
>I appreciate any help I could get.
>
>William
>
>
>

well.... it is JB2005 bug.... a big one.... class 5....
 

Re:Layout and Designer problems Jbuilder 8,9,10 to 2005

CaptnTony wrote:
Quote
So what can we do to help get this 'bug' resolved?
More specific examples might help. Descriptions like, "I have some code
that worked before. It doesn't work now," aren't likely to lead to a
solution quickly.
--
Gillmer J. Derge [TeamB]
 

Re:Layout and Designer problems Jbuilder 8,9,10 to 2005

CaptnTony wrote:
Quote
I have an idea - allow me to disable the designer's attempt
to create 'live' representations of my components!
Isn't that what Beans.isDesignTime() is all about? You do
if (Beans.isDesignTime())
return;
in your constructor. (That is, if all you want to show as a "preview" is
a blank box).