Board index » jbuilder » Problem using the JBuilder de{*word*81} in Windows XP

Problem using the JBuilder de{*word*81} in Windows XP


2004-02-06 01:43:16 AM
jbuilder19
I downloaded the personal edition of JBuilder and I'm able to compile and run a program, but an error is generated every time I try to debug the program ("step into" or "Debug Project") When I select F7 to invoke the de{*word*81}, the activity monitor dialog is launched with a message that it is "Initializing the Java virtual machine", then the following error message is displayed:
Note the error occurs debugging welcome.jpx.
Thank you very, much in advance for your help.
-- Cannot start Java debug process VM --
com.sun.jdi.connect.VMStartException: VM initialization failed for: C:\JBuilder9\jdk1.4\bin\javaw -classpath "C:\JBuilder9\samples\Welcome\classes;C:\JBuilder9\jdk1.4\demo\jfc\Java2D\Java2Demo.jar;C:\JBuilder9\jdk1.4\demo\plugin\jfc\Java2D\Java2Demo.jar;C:\JBuilder9\jdk1.4\jre\lib\charsets.jar;C:\JBuilder9\jdk1.4\jre\lib\ext\dnsns.jar;C:\JBuilder9\jdk1.4\jre\lib\ext\ldapsec.jar;C:\JBuilder9\jdk1.4\jre\lib\ext\localedata.jar;C:\JBuilder9\jdk1.4\jre\lib\ext\sunjce_provider.jar;C:\JBuilder9\jdk1.4\jre\lib\im\indicim.jar;C:\JBuilder9\jdk1.4\jre\lib\jaws.jar;C:\JBuilder9\jdk1.4\jre\lib\jce.jar;C:\JBuilder9\jdk1.4\jre\lib\jsse.jar;C:\JBuilder9\jdk1.4\jre\lib\rt.jar;C:\JBuilder9\jdk1.4\jre\lib\sunrsasign.jar;C:\JBuilder9\jdk1.4\lib\dt.jar;C:\JBuilder9\jdk1.4\lib\htmlconverter.jar;C:\JBuilder9\jdk1.4\lib\tools.jar" -Xdebug -Xnoagent -Djava.compiler=NONE -Xrunjdwp:transport=dt_socket,address=TJsLaptop:1309,suspend=y com.borland.samples.welcome.WelcomeApp
err:: No such file or directory
Error [2] in connect() call!
Socket transport failed to init.
Transport dt_socket failed to initialize, rc = -1.
 
 

Re:Problem using the JBuilder de{*word*81} in Windows XP

tjakowenko wrote:
Quote
I downloaded the personal edition of JBuilder and I'm able to compile
and run a program, but an error is generated every time I try to
debug the program ("step into" or "Debug Project") When I select F7
to invoke the de{*word*81}, the activity monitor dialog is launched with
a message that it is "Initializing the Java virtual machine", then
the following error message is displayed: Note the error occurs
debugging welcome.jpx.

Thank you very, much in advance for your help.

-- Cannot start Java debug process VM --
com.sun.jdi.connect.VMStartException: VM initialization failed for:
C:\JBuilder9\jdk1.4\bin\javaw -classpath
"C:\JBuilder9\samples\Welcome\classes;C:\JBuilder9\jdk1.4\demo\jfc\Java2D\Java2Demo.jar;C:\JBuilder9\jdk1.4\demo\plugin\jfc\Java2D\Java2Demo.jar;C:\JBuilder9\jdk1.4\jre\lib\charsets.jar;C:\JBuilder9\jdk1.4\jre\lib\ext\dnsns.jar;C:\JBuilder9\jdk1.4\jre\lib\ext\ldapsec.jar;C:\JBuilder9\jdk1.4\jre\lib\ext\localedata.jar;C:\JBuilder9\jdk1.4\jre\lib\ext\sunjce_provider.jar;C:\JBuilder9\jdk1.4\jre\lib\im\indicim.jar;C:\JBuilder9\jdk1.4\jre\lib\jaws.jar;C:\JBuilder9\jdk1.4\jre\lib\jce.jar;C:\JBuilder9\jdk1.4\jre\lib\jsse.jar;C:\JBuilder9\jdk1.4\jre\lib\rt.jar;C:\JBuilder9\jdk1.4\jre\lib\sunrsasign.jar;C:\JBuilder9\jdk1.4\lib\dt.jar;C:\JBuilder9\jdk1.4\lib\htmlconverter.jar;C:\JBuilder9\jdk1.4\lib\tools.jar"
-Xdebug -Xnoagent -Djava.compiler=NONE
-Xrunjdwp:transport=dt_socket,address=TJsLaptop:1309,suspend=y
com.borland.samples.welcome.WelcomeApp err:: No such file or
directory Error [2] in connect() call! Socket transport failed to
init. Transport dt_socket failed to initialize, rc = -1.

Generally, this is going to be some kind of firewall issue. Note that
JBuilder is attempting to connect to port 1309 on the machine TJsLaptop.
If your firewall settings do not allow connections on this port,
you'll get this kind of error.
--
Regards,
Lori Olson (TeamB)
------------
Save yourself, and everyone else, some time and search the
newsgroups and the FAQ-O-Matic before posting your next
question.
Google Advanced Newsgroup Search
www.google.ca/advanced_group_search
Other Newsgroup Searches:
www.borland.com/newsgroups/ngsearch.html
Joi Ellis's FAQ-O-Matic:
www.visi.com/~gyles19/fom-serve/cache/1.html