Board index » jbuilder » Flakeyness

Flakeyness


2005-08-15 12:18:28 AM
jbuilder14
Could someone give me a clue as to thy this may be happening?
It's simple. I have 3-4 items on the Design tab. Let's say, a
button, 2 text labels and a text field. I select them all,
right click "align left", run it and a couple of the objects 'disappear' from the window both on the run and back on the Design tab. They are in the source - nothing changed -
they just don't render anymore.
Thanks
 
 

Re:Flakeyness

Paul wrote:
Quote
Could someone give me a clue as to thy this may be happening?

It's simple. I have 3-4 items on the Design tab. Let's say, a
button, 2 text labels and a text field. I select them all, right
click "align left", run it and a couple of the objects 'disappear'
from the window both on the run and back on the Design tab. They
are in the source - nothing changed - they just don't render
anymore.
The fact that you are using "align left" leads me to
believe that you are using the XYLayout layout manager.
That's fine for getting things initially laid out, but
you are encouraged to switch to some other layout
before running. My guess is that the coordinates
for the objects which disappear are somehow getting
set to some location off screen.
Take the time to learn how to use the GridBagLayout.
Yes, it is difficult, but the rewards will more than
compensate for the slight pain of being disciplined
to learn it.
Also, you don't mention which version of JBuilder
you are using. If it is 2005, make sure that you
have downloaded and installed the most recent
update (update 4, I believe). With 2005, the
UI designer is new and there were some significant
issues with it which were mostly corrected in the
various updates that have been released.
--
Paul Furbacher (TeamB)
Save time, search the archives:
info.borland.com/newsgroups/ngsearch.html
Is it in Joi Ellis's Faq-O-Matic?
www.visi.com/~gyles19/fom-serve/cache/1.html
Finally, please send responses to the newsgroup only.
That means, do not send email directly to me.
Thank you.
 

Re:Flakeyness

"Paul Furbacher [TeamB]" < XXXX@XXXXX.COM >wrote:
Quote
Paul wrote:

>Could someone give me a clue as to thy this may be happening?
>
>It's simple. I have 3-4 items on the Design tab. Let's say, a
>button, 2 text labels and a text field. I select them all, right
>click "align left", run it and a couple of the objects 'disappear'
>from the window both on the run and back on the Design tab. They
>are in the source - nothing changed - they just don't render
>anymore.

The fact that you are using "align left" leads me to
believe that you are using the XYLayout layout manager.
That's fine for getting things initially laid out, but
you are encouraged to switch to some other layout
before running. My guess is that the coordinates
for the objects which disappear are somehow getting
set to some location off screen.

Take the time to learn how to use the GridBagLayout.
Yes, it is difficult, but the rewards will more than
compensate for the slight pain of being disciplined
to learn it.


Also, you don't mention which version of JBuilder
you are using. If it is 2005, make sure that you
have downloaded and installed the most recent
update (update 4, I believe). With 2005, the
UI designer is new and there were some significant
issues with it which were mostly corrected in the
various updates that have been released.

At this stage of the game, I'm not using any layout manager
<null>. This problem happens when I shift click the items on
the design tab just to get things straighten out. After
reading and going through all the layout tutorials, and from
what I've read, I plan on using GridBagLayout - if I can get
away from restoring from backup every other adjustment.
Which brings up another question: Is there a facility for
restoring from the backups? I've just been doing the cut-paste
thing. Doesn't seem real elegant.
As far as the update goes, I'm less than 30 days on the
version I have. How would I know what/if I need? There is
nothing in the help or on the main menu.
BTW - Thanks for your help.
Paul
 

{smallsort}

Re:Flakeyness

paul wrote:
Quote
Which brings up another question: Is there a facility for
restoring from the backups? I've just been doing the cut-paste
thing. Doesn't seem real elegant.
You don't say which edition (Foundation, Developer, Enterprise)
you are using, but at least in the latter two, there's a "History"
tab at the bottom of the editor pane. Once you click on that,
you'll see a "Diff" tab. Pick the two versions you want, and
undo changes as needed.
Quote
As far as the update goes, I'm less than 30 days on the
version I have. How would I know what/if I need? There is
nothing in the help or on the main menu.
The About box should give you the build and update numbers.
The build should be 11.0.320.0 and the update should be 4
for JBuilder 2005.
--
Paul Furbacher (TeamB)
Save time, search the archives:
info.borland.com/newsgroups/ngsearch.html
Is it in Joi Ellis's Faq-O-Matic?
www.visi.com/~gyles19/fom-serve/cache/1.html
Finally, please send responses to the newsgroup only.
That means, do not send email directly to me.
Thank you.