Board index » kylix » I got Kylix 3 OE running on SUSe 9.1, but!!

I got Kylix 3 OE running on SUSe 9.1, but!!


2004-05-28 04:10:15 AM
kylix0
Hi all
I used the method given in another thread to get Kylix 3 up and running but
if I try to compile or run my app Kylix bombs out. This app although not
complete does run ok under SUSe 8.0. If I start Kylix from a console
session I get the following message when it bombs.
bcblin: ../VMem.c:90: AutoSetLastError: Assertion `!"Bad error code"'
failed.
/usr/local/kylix3/bin/startbcb: line 25: 4459
Killed /usr/local/kylix3/bin/bcblin $*
Does anyone know how to solve this problem.
TIA
Stewart
 
 

Re:I got Kylix 3 OE running on SUSe 9.1, but!!

I got the same problem.
I thinks its because the linker sucks!!!
Stewart Taylor wrote:
Quote
Hi all

I used the method given in another thread to get Kylix 3 up and running but
if I try to compile or run my app Kylix bombs out. This app although not
complete does run ok under SUSe 8.0. If I start Kylix from a console
session I get the following message when it bombs.

bcblin: ../VMem.c:90: AutoSetLastError: Assertion `!"Bad error code"'
failed.
/usr/local/kylix3/bin/startbcb: line 25: 4459
Killed /usr/local/kylix3/bin/bcblin $*

Does anyone know how to solve this problem.

TIA

Stewart
 

Re:I got Kylix 3 OE running on SUSe 9.1, but!!

Hi Stewart
Any luck yet, I have exactly the same problem!!!!
Thanks!!!
Gerard
Stewart Taylor < XXXX@XXXXX.COM >wrote in message news:< XXXX@XXXXX.COM >...
Quote
Hi all

I used the method given in another thread to get Kylix 3 up and running but
if I try to compile or run my app Kylix bombs out. This app although not
complete does run ok under SUSe 8.0. If I start Kylix from a console
session I get the following message when it bombs.

bcblin: ../VMem.c:90: AutoSetLastError: Assertion `!"Bad error code"'
failed.
/usr/local/kylix3/bin/startbcb: line 25: 4459
Killed /usr/local/kylix3/bin/bcblin $*

Does anyone know how to solve this problem.

TIA

Stewart
 

{smallsort}

Re:I got Kylix 3 OE running on SUSe 9.1, but!!

Stewart Taylor wrote:
Quote
Hi all

I used the method given in another thread to get Kylix 3 up and running but
if I try to compile or run my app Kylix bombs out. This app although not
complete does run ok under SUSe 8.0. If I start Kylix from a console
session I get the following message when it bombs.

bcblin: ../VMem.c:90: AutoSetLastError: Assertion `!"Bad error code"'
failed.
/usr/local/kylix3/bin/startbcb: line 25: 4459
Killed /usr/local/kylix3/bin/bcblin $*

Does anyone know how to solve this problem.

TIA

Stewart
It is apparently caused by something in the 2.6.x kernel.
Fedora Core 2 has the same problem .
I am not aware of any solution other than to run and older version of
linux that uses the 2.4.x kernel.