Board index » kylix » kylix3 ide not working under libc-2.3.4

kylix3 ide not working under libc-2.3.4


2005-04-27 08:43:48 PM
kylix1
I shortly installed Linux ( self compiled Linux from the scratch Version 6,
Kernel 2.6.8, libc-2.3.4 ) and after that kylix3.
The installation of kylix went OK, however, "startkylix" crashes with errors
related to the libraries 2.3.4 ( "bin/bash: error while loading shared
libraries: libdl.so.2: cannot open shared object file: no such file or
directory " ) libdl.so.2 points to libdl-2.3.4.so. changing the link to
libdl-2.3.3.so avoids this error but brings a next one up related to
libc-2.3.4.
What can I do ? downgrading my system to the 2.3.3 libraries does not seem
to be a "progressive" solution. I did also not find this problem googling
through.
Thanks in advance,
Edgar
 
 

Re:kylix3 ide not working under libc-2.3.4

Dr. Edgar Alwers wrote:
Quote
I shortly installed Linux ( self compiled Linux from the scratch Version 6,
Kernel 2.6.8, libc-2.3.4 ) and after that kylix3.
The installation of kylix went OK, however, "startkylix" crashes with errors
related to the libraries 2.3.4 ( "bin/bash: error while loading shared
libraries: libdl.so.2: cannot open shared object file: no such file or
..
sorry, this has been replied to soooo many times. search google for
'LD_ASSUME_KERNEL='
export LD_ASSUME_KERNEL=2.4.21
Put this line into your startdelphi script in the kylix3 bin directory..
I use export LD_ASSUME_KERNEL=2.4.21
good luck :)
siegs
 

Re:kylix3 ide not working under libc-2.3.4

siegfriedn wrote:
Quote
sorry, this has been replied to soooo many times. search google for
'LD_ASSUME_KERNEL='


export LD_ASSUME_KERNEL=2.4.21

Put this line into your startdelphi script in the kylix3 bin directory..

I use export LD_ASSUME_KERNEL=2.4.21
Sorry, nope !
I had of course googled the issue and I had delivered that LD_ASSUME... The
point is the _then _following_ error, which points exactly to the wrong
libc-2.3.4. And there are no google postings to this problem ! This second
error vanishes if I load instead the libc-2.3.3, but this is a major
intervention in a brand new Linux system. As I said in my other posting,
the linux caravane continues going and Borland/kylix seems to remain still
standing and waiting what happens :-(
But thank you anyway for your help !
Edgar
 

{smallsort}

Re:kylix3 ide not working under libc-2.3.4

Dr. Edgar Alwers wrote:
Quote
I shortly installed Linux ( self compiled Linux from the scratch Version
6, Kernel 2.6.8, libc-2.3.4 ) and after that kylix3.
The installation of kylix went OK, however, "startkylix" crashes with
errors related to the libraries 2.3.4 ( "bin/bash: error while loading
shared libraries: libdl.so.2: cannot open shared object file: no such file
or directory " ) libdl.so.2 points to libdl-2.3.4.so. changing the link to
libdl-2.3.3.so avoids this error but brings a next one up related to
libc-2.3.4.
What can I do ? downgrading my system to the 2.3.3 libraries does not seem
to be a "progressive" solution. I did also not find this problem googling
through.
Thanks in advance,
Edgar
[linda@houston ~]$ rpm -qa | grep -i glibc
glibc-headers-2.3.4-2.fc3
glibc-utils-2.3.4-2.fc3
glibc-2.3.5-0.fc3.1
glibc-2.3.4-2.fc3
glibc-profile-2.3.4-2.fc3
glibc-devel-2.3.4-2.fc3
glibc-kernheaders-2.4-9.1.87
glibc-common-2.3.4-2.fc3
works like a charm, except I've installed 2.3.5 (Fc3 update) , and then I
have to downgrade glibc to 2.3.4, cause k3 hangs on new package install.
so K3 on glibc-2.3.4 w/o problems.
Try this as root:
echo 1>/proc/sys/vm/legacy_va_layout
and then as user
export LD_ASSUME_KERNEL=2.4.1
startdelphi
 

Re:kylix3 ide not working under libc-2.3.4

zeljko wrote:
Quote
Try this as root:
echo 1>/proc/sys/vm/legacy_va_layout
I dont have legacy_va_layout in /proc/sys/vm, I dont know why. So i shall
see how to get it installed, as it seems to be the only diference we have.
Giving export ASSUME_KERNEL=2.4.1 and startdelphi alone gives permanent an
error refering to the 2.3.4 libraries. Anyhow, I am glad to hear, that you
are managing kylix3 on a system with libc-2.3.4 as I have. I will try to
solve the legacy issue and then come back again.
Meanwhile thank you very much !
Edgar,
Weinheim/Germany
Quote

and then as user
export LD_ASSUME_KERNEL=2.4.1
startdelphi
 

Re:kylix3 ide not working under libc-2.3.4

Quote
I dont have legacy_va_layout in /proc/sys/vm, I dont know why. So i shall
ooops .... you are running 2.6.8 ... why don't you install some more recent
kernel like 2.6.11
 

Re:kylix3 ide not working under libc-2.3.4

zeljko wrote:
Quote
>I dont have legacy_va_layout in /proc/sys/vm, I dont know why. So i shall

ooops .... you are running 2.6.8 ... why don't you install some more
recent kernel like 2.6.11
well, I downloaded and compiled kernel-2.6.11.8. Now at least I have
legacy_va_layout. I did as you instructed, but the result is still the same
"libc.so.6: cannot open shared object file: No such file or directory"
libc.so.6 exists, of course, but is pointing to libc-2.3.4.so, and kylix
does not like this, at least in my case. Very frustating :-(
Edgar