Board index » kylix » Re: Code error

Re: Code error


2005-12-01 04:24:59 AM
kylix1
John Meyer wrote:
Quote
I put up the snapshot in borland.public.attachments as to what it
looks like (using firefox)
Funny. Can you try this command in the console:
wget
rpmfind.net/linux/redhat/7.3/en/os/i386/RedHat/RPMS/compat-glibc-6.2-2.1.3.2.i386.rpm
Jonathan
 
 

Re:Re: Code error

Jonathan Benedicto wrote:
Quote
John Meyer wrote:

>I put up the snapshot in borland.public.attachments as to what it
>looks like (using firefox)


Funny. Can you try this command in the console:

wget
rpmfind.net/linux/redhat/7.3/en/os/i386/RedHat/RPMS/compat-glibc-6.2-2.1.3.2.i386.rpm

Jonathan


no such directory "/linux/redhat/7.3/en/os/i386/RedHat/RPMS/"
 

Re:Re: Code error

Jonathan Benedicto wrote:
Quote
John Meyer wrote:

>I put up the snapshot in borland.public.attachments as to what it
>looks like (using firefox)


Funny. Can you try this command in the console:

wget
rpmfind.net/linux/redhat/7.3/en/os/i386/RedHat/RPMS/compat-glibc-6.2-2.1.3.2.i386.rpm

Jonathan


Hold on, I did a web search and I got it.
 

{smallsort}

Re:Re: Code error

John Meyer wrote:
Quote
Hold on, I did a web search and I got it.
Ok, I had just uploaded it to my own server so that you could get it.
Jonathan
 

Re:Re: Code error

Jonathan Benedicto wrote:
Quote
John Meyer wrote:

>Hold on, I did a web search and I got it.


Ok, I had just uploaded it to my own server so that you could get it.

Jonathan


Works like a charm, now all I have to do is downgrade my kernel so I can
use the run button in the IDE.
 

Re:Re: Code error

John Meyer wrote:
Quote
Works like a charm, now all I have to do is downgrade my kernel so I
can use the run button in the IDE.
Yeah. You could write your own IDE plugin that compiles and runs the app.
Jonathan
 

Re:Re: Code error

Jonathan Benedicto wrote:
Quote
John Meyer wrote:
>Works like a charm, now all I have to do is downgrade my kernel so I
>can use the run button in the IDE.

Yeah. You could write your own IDE plugin that compiles and runs the app.

Jonathan
Yeah, btw, is compat-glibc-6.2-2.1.3.2.i386.rpm still on your system. I
need that file.
 

Re:Re: Code error

John Meyer wrote:
Quote
Yeah, btw, is compat-glibc-6.2-2.1.3.2.i386.rpm still on your system.
I need that file.
Yup, www.jomitech.com/downloads/compat-glibc-6.2-2.1.3.2.i386.rpm
Jonathan
 

Re:Re: Code error

Jonathan Benedicto wrote:
Quote
John Meyer wrote:

>Yeah, btw, is compat-glibc-6.2-2.1.3.2.i386.rpm still on your system.
>I need that file.


Yup, www.jomitech.com/downloads/compat-glibc-6.2-2.1.3.2.i386.rpm

Jonathan


Thanks and got it. BTW, do you know of a good document to use for
compiling and installing a kernel? I need to do it to have Kylix work,
but I don't know what options are compiled in my kernel (it was standard
with SuSE Linux 10).
 

Re:Re: Code error

John Meyer wrote:
Quote
Thanks and got it. BTW, do you know of a good document to use for
compiling and installing a kernel? I need to do it to have Kylix
work, but I don't know what options are compiled in my kernel (it was
standard with SuSE Linux 10).
No I don't. I'm really inexperienced at Linux.
However, if I wanted Kylix, I'd get Gentoo and install the 2.4 kernel, as
Gentoo allows you to choose whether you want the 2.4 or 2.6 kernel.
Jonathan
 

Re:Re: Code error

Jonathan Benedicto wrote:
Quote
John Meyer wrote:

>Thanks and got it. BTW, do you know of a good document to use for
>compiling and installing a kernel? I need to do it to have Kylix
>work, but I don't know what options are compiled in my kernel (it was
>standard with SuSE Linux 10).


No I don't. I'm really inexperienced at Linux.

However, if I wanted Kylix, I'd get Gentoo and install the 2.4 kernel, as
Gentoo allows you to choose whether you want the 2.4 or 2.6 kernel.

Jonathan


I may have to do that, in the near future. Anyway, thanks for the help
(I now have that file backed up, thank god).
 

Re:Re: Code error

John Meyer wrote:
Quote
SuSE Linux 10
I have the bc++ compiler working with the glibc that ships with SUSE 10.
(But the linker crashes).
I should collect the changes I made to the header files and then pack them
to an tar ball. I really should do that. (Have you known that the Kylix 3
C++ compiler is version 5.7 but the Windows compiler is still 5.6.4)
--
Regards,
Andreas Hausladen
(www.kylix-patch.de.vu - unofficial Kylix 3 patches)
(andy.jgknet.de/blog)
 

Re:Re: Code error

Andreas Hausladen wrote:
Quote
I should collect the changes I made to the header files and then pack
them to an tar ball. I really should do that. (Have you known that the
Kylix 3 C++ compiler is version 5.7 but the Windows compiler is still
5.6.4)
Now the patch can be downloaded:
tinyurl.com/7ccsq
andy.jgknet.de/oss/kylix/wiki/index.php/Include_directory_patch
--
Regards,
Andreas Hausladen
(www.kylix-patch.de.vu - unofficial Kylix 3 patches)
(andy.jgknet.de/blog)
 

Re:Re: Code error

Andreas Hausladen wrote:
Quote
Andreas Hausladen wrote:


>I should collect the changes I made to the header files and then pack
>them to an tar ball. I really should do that. (Have you known that the
>Kylix 3 C++ compiler is version 5.7 but the Windows compiler is still
>5.6.4)


Now the patch can be downloaded:
tinyurl.com/7ccsq
andy.jgknet.de/oss/kylix/wiki/index.php/Include_directory_patch



Does this fix the error where Kylix crashes when it attempts to use the
auto-complete function?
 

Re:Re: Code error

John Meyer wrote:
Quote
Does this fix the error where Kylix crashes when it attempts to use the
auto-complete function?
I don''t know. This patch allows me to compile files with the command line
compiler bc++. I have not used Kylix C++ for years.
In the patch there is also an removepatch.sh script that reverts the
changes. So it sould be safe to test the patch without harming other
projects. (But that does not mean that you should not backup your include
directory if you install the patch)
--
Regards,
Andreas Hausladen
(www.kylix-patch.de.vu - unofficial Kylix 3 patches)
(andy.jgknet.de/blog)