Board index » kylix » Problem to install kylix on Ubuntu

Problem to install kylix on Ubuntu


2006-03-26 07:52:48 AM
kylix0
I have this error message :
:~/kylix3/bin$ ./startkylix
Note: Please start the Delphi portion of Kylix with the startdelphi command.
/kylix3/bin/delphi: relocation error: /kylix3/bin/libwine.borland.so: symbol errno, version GLIBC_2.0 not defined in file libc.so.6 with link time reference
Could anybody help me ?
 
 

Re:Problem to install kylix on Ubuntu

yasoft wrote:
Quote

I have this error message :
:~/kylix3/bin$ ./startkylix
Note: Please start the Delphi portion of Kylix with the startdelphi
command. /kylix3/bin/delphi: relocation error:
/kylix3/bin/libwine.borland.so: symbol errno, version GLIBC_2.0 not
defined in file libc.so.6 with link time reference

Could anybody help me ?
same problem with FC5, ubuntu have glibc-2.4 ?
 

Re:Problem to install kylix on Ubuntu

zeljko < XXXX@XXXXX.COM >wrote:
Quote
yasoft wrote:

>
>I have this error message :
>:~/kylix3/bin$ ./startkylix
>Note: Please start the Delphi portion of Kylix with the startdelphi
>command. /kylix3/bin/delphi: relocation error:
>/kylix3/bin/libwine.borland.so: symbol errno, version GLIBC_2.0 not
>defined in file libc.so.6 with link time reference
>
>Could anybody help me ?

same problem with FC5, ubuntu have glibc-2.4 ?
When I install kylix, it says that it is ok with the version of glibc. But after the installation, it doesn't work and I have the error message just above.
So I don't know what is the problem.
Yasoft.
 

{smallsort}

Re:Problem to install kylix on Ubuntu

yasoft wrote:
Quote

zeljko < XXXX@XXXXX.COM >wrote:
>yasoft wrote:
>
>>
>>I have this error message :
>>:~/kylix3/bin$ ./startkylix
>>Note: Please start the Delphi portion of Kylix with the startdelphi
>>command. /kylix3/bin/delphi: relocation error:
>>/kylix3/bin/libwine.borland.so: symbol errno, version GLIBC_2.0 not
>>defined in file libc.so.6 with link time reference
>>
>>Could anybody help me ?
>
>same problem with FC5, ubuntu have glibc-2.4 ?

When I install kylix, it says that it is ok with the version of glibc. But
after the installation, it doesn't work and I have the error message just
above. So I don't know what is the problem.
glibc-2.4 is the problem (doesn't use linuxthreads anymore, so it breaks old
winelib (k3 ide is compiled against ancient winelib)).
 

Re:Problem to install kylix on Ubuntu

zeljko wrote:
Quote
yasoft wrote:


>zeljko < XXXX@XXXXX.COM >wrote:
>
>>yasoft wrote:
>>
>>
>>>I have this error message :
>>>:~/kylix3/bin$ ./startkylix
>>>Note: Please start the Delphi portion of Kylix with the startdelphi
>>>command. /kylix3/bin/delphi: relocation error:
>>>/kylix3/bin/libwine.borland.so: symbol errno, version GLIBC_2.0 not
>>>defined in file libc.so.6 with link time reference
>>>
>>>Could anybody help me ?
>>
>>same problem with FC5, ubuntu have glibc-2.4 ?
>
>When I install kylix, it says that it is ok with the version of glibc. But
>after the installation, it doesn't work and I have the error message just
>above. So I don't know what is the problem.


glibc-2.4 is the problem (doesn't use linuxthreads anymore, so it breaks old
winelib (k3 ide is compiled against ancient winelib)).
So.. What we must to do to take it work ?? <:S