Board index » kylix » Kylix and 2.6.0

Kylix and 2.6.0


2004-01-04 10:27:02 PM
kylix2
Hi all.
I saw some post that K3 doesn't work with kernel 2.6.0, and I read that even
someone is "happy that he didn't bought K3" cause of that.
So, till now I didn't check is that true or not, so today I install kernel
2.6.0.
What I want to say:
By my opinion, Kylix 3 works with 2.6.0 even better ( and definitely faster)
than previous 2.4.x versions.
So, please, check such things first, before to say something like that.
Thank you.
Mark.
 
 

Re:Kylix and 2.6.0

On Sun, 04 Jan 2004 15:27:02 +0100, Mark wrote:
Quote
I saw some post that K3 doesn't work with kernel 2.6.0
If you're referring to my post -- I said that it doesn't work with 2.6 and
NPTL. I also offered advice on how to circumvent the problem (by using
non-nptl threading)
johannes
 

Re:Kylix and 2.6.0

Mark wrote:
Quote
So, please, check such things first, before to say something like that.
most of the complainers are seemingly using the C++ version.
The Delphi version of Kylix seems to cause far less trouble.
Personaly I've not had much problems installing and using
Kylix Delphi V1, V2 and V3 on over a dozend Linux distros,
just out of curiousity.
I've a Shuttle SN41G2 which I use only to play with Betas
and newer Distros.
Usualy I've three different Linux Distros installed on it.
So far I haven't installed any 2.6 kernel.
Martin
 

{smallsort}

Re:Kylix and 2.6.0

On 01/04/04 23:27 +0900, Mark wrote:
Quote
I saw some post that K3 doesn't work with kernel 2.6.0, and I read that even
someone is "happy that he didn't bought K3" cause of that.
When Andreas Hausladen states "new kernel 2.6 and Kylix will not
really work with this kernel," I am inclined to believe him.
Quote
So, till now I didn't check is that true or not, so today I install kernel
2.6.0.
What I want to say:
By my opinion, Kylix 3 works with 2.6.0 even better ( and definitely faster)
than previous 2.4.x versions.
Is this the case with both Delphi and BCB?
Quote
So, please, check such things first, before to say something like that.
I'm only running 2.4.23 here, so I have no choice but to trust
whom I consider to be reliable sources of information. If Kylix,
both Delphi and BCB work better under 2.6 than under the 2.4
kernels, all the better for everybody.
Till such time as I can be sure that K3 will work well with 2.6,
I will continue playing with K3OE and not purchase Pro.
trane
--
//------------------------------------------------------------
// Trane Francks XXXX@XXXXX.COM Tokyo, Japan
// Practice random kindness and senseless acts of beauty.
 

Re:Kylix and 2.6.0

Trane Francks wrote:
Quote
When Andreas Hausladen states "new kernel 2.6 and Kylix will not really
work with this kernel," I am inclined to believe him.
No, do not believe me. I just sayed what I read from someone in a web
based forum. I never tested it.
--
Regards,
Andreas Hausladen
(www.kylix-patch.de.vu - Kylix 3 patches)
 

Re:Kylix and 2.6.0

Well here's a personal experience with Kylix 3 Delphi running on RH9 -
doesn't work. I can start up kylix, but it hangs when I attempt to build my
project. If I force it to use kernel 2.4, everything is fine.
"Mark" < XXXX@XXXXX.COM >wrote in message
Quote
Hi all.

I saw some post that K3 doesn't work with kernel 2.6.0, and I read that
even
someone is "happy that he didn't bought K3" cause of that.
So, till now I didn't check is that true or not, so today I install kernel
2.6.0.
What I want to say:
By my opinion, Kylix 3 works with 2.6.0 even better ( and definitely
faster)
than previous 2.4.x versions.
So, please, check such things first, before to say something like that.

Thank you.
Mark.


 

Re:Kylix and 2.6.0

"Wendy Carson" < XXXX@XXXXX.COM >wrote in message
Quote
Well here's a personal experience with Kylix 3 Delphi running on RH9 -
doesn't work. I can start up kylix, but it hangs when I attempt to build
my
project. If I force it to use kernel 2.4, everything is fine.

With standard kernel of RH9 ( 2.4.1x - I don't remember exactly ) Kylix 3
works, but not so stable, but with 2.4.21 work just fine.
And if you don't want to have problems with it - take last one form RH -
Fedora Core 1 with kernel 2.4.22 and forget about the problems.
 

Re:Kylix and 2.6.0

Try adding the following line to your startkylix script
export LD_ASSUME_KERNEL=2.2.5
this worked great for me under RH9 before using this my IDE hung every
time I tried to run an app.
Kevin
"Mark" < XXXX@XXXXX.COM >wrote in message news:<3ff9c20c$ XXXX@XXXXX.COM >...
Quote
"Wendy Carson" < XXXX@XXXXX.COM >wrote in message
news: XXXX@XXXXX.COM ...
>Well here's a personal experience with Kylix 3 Delphi running on RH9 -
>doesn't work. I can start up kylix, but it hangs when I attempt to build
my
>project. If I force it to use kernel 2.4, everything is fine.
>

With standard kernel of RH9 ( 2.4.1x - I don't remember exactly ) Kylix 3
works, but not so stable, but with 2.4.21 work just fine.
And if you don't want to have problems with it - take last one form RH -
Fedora Core 1 with kernel 2.4.22 and forget about the problems.
 

Re:Kylix and 2.6.0

El Sun, 04 Jan 2004 15:27:02 +0100, Mark escribi?
Quote
Hi all.

I saw some post that K3 doesn't work with kernel 2.6.0, and I read that even
someone is "happy that he didn't bought K3" cause of that.
So, till now I didn't check is that true or not, so today I install kernel
2.6.0.
What I want to say:
By my opinion, Kylix 3 works with 2.6.0 even better ( and definitely faster)
than previous 2.4.x versions.
So, please, check such things first, before to say something like that.

Also here, work perfect with 2.6.
Maybe C++ version have problems. I use Delphy/Kylix off course.
Best regards.
German Gentile.
 

Re:Kylix and 2.6.0

German Pablo Gentile (MaxKalZone) wrote:
Quote
Delphy/Kylix off course.

Best regards.

German Gentile.

How's that for an out of context quote?
 

Re:Kylix and 2.6.0

On Mon, 05 Jan 2004 12:53:04 -0500, Wendy Carson wrote:
Quote
Well here's a personal experience with Kylix 3 Delphi running on RH9 -
doesn't work. I can start up kylix, but it hangs when I attempt to build
my project. If I force it to use kernel 2.4, everything is fine.
Have you tried to start using
LD_ASSUME_KERNEL=2.4 startdelphi
?
In that case, you force glibc to use non-kernel threading (via processes
instead of kernel-threads), and this is something kylix apparently
requires.
johannes
 

Re:Kylix and 2.6.0

Not true, I am using K3 with 2.6.1-rc1-mm2 and it works great, it's actually
much snappier and runs better than on 2.4.
I am running on Gentoo 1.4 by the way.
"Mark" < XXXX@XXXXX.COM >wrote in message
Quote
Hi all.

I saw some post that K3 doesn't work with kernel 2.6.0, and I read that
even
someone is "happy that he didn't bought K3" cause of that.
So, till now I didn't check is that true or not, so today I install kernel
2.6.0.
What I want to say:
By my opinion, Kylix 3 works with 2.6.0 even better ( and definitely
faster)
than previous 2.4.x versions.
So, please, check such things first, before to say something like that.

Thank you.
Mark.


 

Re:Kylix and 2.6.0

Quote
I am using K3 with 2.6.1-rc1-mm2 and it works great,
Nice to hear that.
BTW.: I tried to compile 2.6.0 but I got a compiler error (using gcc 2.7
instead the 2.6 as recommended when I recall correctly).
Where to get 2.6.1 ? It's not on kernel.org.
-Michael
 

Re:Kylix and 2.6.0

Michael Schnell wrote:
Quote
>I am using K3 with 2.6.1-rc1-mm2 and it works great,


Nice to hear that.

BTW.: I tried to compile 2.6.0 but I got a compiler error (using gcc 2.7
instead the 2.6 as recommended when I recall correctly).
gcc 2.7 is really old, either use gcc 2.95 or 3.3 or so.
Quote
Where to get 2.6.1 ? It's not on kernel.org.
2.6.1-xxx are prereleases for 2.6.1, 2.6.1 still has to arive. rc1 means
release candidate 1. -mm2 means andrew morton's (iirc) patches applied,
second release.
HTH,
Micha.
 

Re:Kylix and 2.6.0

Quote
>BTW.: I tried to compile 2.6.0 but I got a compiler error (using gcc 2.7
>instead the 2.6 as recommended when I recall correctly).

gcc 2.7 is really old, either use gcc 2.95 or 3.3 or so.

The version I used was one point higher in the last number than the one
recommended. If 2.95 was recommended, I think I used 2.96).
-Michael