Board index » kylix » Kylix 3 and Fedora 4 ???

Kylix 3 and Fedora 4 ???


2005-10-02 11:22:04 AM
kylix2
Hi,
I'd installed K3 in Fedora4 successfully. But when run startdelphi get error
message and K3 stopped. Are there any one can run K3 in F4 ?
Best regard
 
 

Re:Kylix 3 and Fedora 4 ???

San wrote:
Quote
Hi,
I'd installed K3 in Fedora4 successfully. But when run startdelphi get
error message and K3 stopped. Are there any one can run K3 in F4 ?
Kylix 3 hangs on Fc4 because of glibc 2.3.5.Try to downgrade glibc (not
recommended).
 

Re:Kylix 3 and Fedora 4 ???

San wrote:
Quote
Hi,
I'd installed K3 in Fedora4 successfully. But when run startdelphi get
error message and K3 stopped. Are there any one can run K3 in F4 ?

Best regard
ok ... here is the solution for glibc-2.3.5 :
1. Your startdelphi script must contain something like
export LD_ASSUME_KERNEL=2.4.0
2. As root you must echo 1>/proc/sys/vm/legacy_va_layout
3. When starting kylix you must do it like this eg.
nice -n 10 startdelphi
Yes now it works bit slower, but it can work normally with glibc 2.3.5.
why ? I don't know, I found it by pure coincidence, by running k3 with
strace on glibc-2.3.5.
Now you can use k3 with Fc4, of course without integrated debugging.
 

{smallsort}