Board index » kylix » Kylix 3 (Open Edition) and Ubuntu

Kylix 3 (Open Edition) and Ubuntu


2005-09-07 07:55:27 AM
kylix1
Does anyone know if Kylix 3 runs under Ubuntu? (5.04)
Before setup:
All pretests are ok, but i get the following error during setup (after
line 354):
Checking dependencies...
Kernel version>= 2.2.0....OK
Glibc version>= 2.1.2....OK
X11 Server....OK
Libjpeg version>= 6.2.0....OK
setup.sh: line 350: [: x11-2: integer expression expected
setup.sh: line 352: [: x11-2: integer expression expected
setup.sh: line 354: [: x11-2: integer expression expected
setup.sh: line 350: [: x11-2: integer expression expected
setup.sh: line 352: [: x11-2: integer expression expected
setup.sh: line 354: [: x11-2: integer expression expected
Libgtk version>= 1.2.0....FAILED
(I got the most recent libgtk version)
Any suggestions?
 
 

Re:Kylix 3 (Open Edition) and Ubuntu

Hans Rikartsen wrote:
Quote
Does anyone know if Kylix 3 runs under Ubuntu? (5.04)

Before setup:

All pretests are ok, but i get the following error during setup (after
line 354):

Checking dependencies...
Kernel version>= 2.2.0....OK
Glibc version>= 2.1.2....OK
X11 Server....OK
Libjpeg version>= 6.2.0....OK
setup.sh: line 350: [: x11-2: integer expression expected
setup.sh: line 352: [: x11-2: integer expression expected
setup.sh: line 354: [: x11-2: integer expression expected
setup.sh: line 350: [: x11-2: integer expression expected
setup.sh: line 352: [: x11-2: integer expression expected
setup.sh: line 354: [: x11-2: integer expression expected
Libgtk version>= 1.2.0....FAILED

(I got the most recent libgtk version)


Any suggestions?
I don't have a clue if Kylix 3 will run under Ubuntu but you might
try ./setup.sh -m
Corwin
 

Re:Kylix 3 (Open Edition) and Ubuntu

Hi Corwin,
I made it! It was the fastest and more stable installation since I work
with Kylix.
Take a look on borland.public.kylix.distros-compatibility
Or www.jsk.com.br/kylix-ubuntu.html (it's portuguese but you can get the
main ideas).
Good Luck,
Josir Gomes
Rio de Janeiro - Brasil
Quote
Hans Rikartsen wrote:

>Does anyone know if Kylix 3 runs under Ubuntu? (5.04)
>
>Before setup:
>
>All pretests are ok, but i get the following error during setup (after
>line 354):
>
>Checking dependencies...
>Kernel version>= 2.2.0....OK
>Glibc version>= 2.1.2....OK
>X11 Server....OK
>Libjpeg version>= 6.2.0....OK
>setup.sh: line 350: [: x11-2: integer expression expected
>setup.sh: line 352: [: x11-2: integer expression expected
>setup.sh: line 354: [: x11-2: integer expression expected
>setup.sh: line 350: [: x11-2: integer expression expected
>setup.sh: line 352: [: x11-2: integer expression expected
>setup.sh: line 354: [: x11-2: integer expression expected
>Libgtk version>= 1.2.0....FAILED
>
>(I got the most recent libgtk version)
>
>
>Any suggestions?


I don't have a clue if Kylix 3 will run under Ubuntu but you might

try ./setup.sh -m

Corwin
 

{smallsort}