Board index » kylix » Kylix 3 applications on new linux distros

Kylix 3 applications on new linux distros


2005-11-28 01:02:40 AM
kylix1
Hi,
I know the issues regarding developing Kylix 3 applications on the
latest distros. Would there be any issues releasing applications
written in Kylix 3 on the latest distros?
We develop using the Object Pascal language and mainly write GUI
database applications.
Regards,
- Graeme -
 
 

Re:Kylix 3 applications on new linux distros

Graeme Geldenhuys wrote:
Quote
Hi,

I know the issues regarding developing Kylix 3 applications on the
latest distros. Would there be any issues releasing applications
written in Kylix 3 on the latest distros?
didn't found any problem (Fc4,Fc5-devel,Suse-10), you have to include
execshieldfix unit into your app.
 

Re:Kylix 3 applications on new linux distros

Hello.
Should i add execshieldfix.pas in the executable file only or in the
executable file and
in the all Kylix-libraries which are linked with this executable?
"zeljko" < XXXX@XXXXX.COM >wrote in message
Quote
Graeme Geldenhuys wrote:

>Hi,
>
>I know the issues regarding developing Kylix 3 applications on the
>latest distros. Would there be any issues releasing applications
>written in Kylix 3 on the latest distros?

didn't found any problem (Fc4,Fc5-devel,Suse-10), you have to include
execshieldfix unit into your app.
 

{smallsort}

Re:Kylix 3 applications on new linux distros

Quote
Hello.
Should i add execshieldfix.pas in the executable file only or in the
executable file and
in the all Kylix-libraries which are linked with this executable?
Shared objects (.so's) are not affected by the problem. So, you only
need to add execshieldfix.pas to your main executable. If you are using
CrossKylix, you don't need this at all.
More details on my website:
crosskylix.untergrund.net/execshield.shtml
Simon
 

Re:Kylix 3 applications on new linux distros

Quote
I know the issues regarding developing Kylix 3 applications on the
latest distros. Would there be any issues releasing applications
written in Kylix 3 on the latest distros?

We develop using the Object Pascal language and mainly write GUI
database applications.
Deploying GUI applications to Linux always implies "issues". You'll
have to invest some work into this, just as with non-Kylix solutions.
I guess your real questions was if there are any BLOCKING issues doing
this - then the answer is no, it's doable.
Most important things are: You'll have to care about deployment of the
QT libs. Either bundle them with your application, or maybe make use
of the Kylixlibs project:
kylixlibs.sourceforge.net/down.html
Other than that:
See this:
crosskylix.untergrund.net/execshield.shtml
Simon
 

Re:Kylix 3 applications on new linux distros

Graeme Geldenhuys wrote:
Quote
Hi,

I know the issues regarding developing Kylix 3 applications on the
latest distros. Would there be any issues releasing applications
written in Kylix 3 on the latest distros?

We develop using the Object Pascal language and mainly write GUI
database applications.

Regards,
- Graeme -
I would look at CrossFPC.. You are going to hit several brick walls on newer
distros. They can be overcome, but you will need to do some custom coding
and perhaps packaging in your distribution of the application.
 

Re:Kylix 3 applications on new linux distros

Simon, thank you for the replay. I add your fix in all my Kylix apps.
"Simon Kissel" < XXXX@XXXXX.COM >wrote in message
Quote
Hello.
Should i add execshieldfix.pas in the executable file only or in the
executable file and
in the all Kylix-libraries which are linked with this executable?
Shared objects (.so's) are not affected by the problem. So, you only
need to add execshieldfix.pas to your main executable. If you are using
CrossKylix, you don't need this at all.
More details on my website:
crosskylix.untergrund.net/execshield.shtml
Simon
 

Re:Kylix 3 applications on new linux distros

Oops, replay = reply
"Dmitry" < XXXX@XXXXX.COM >wrote in message
Quote
Simon, thank you for the replay. I add your fix in all my Kylix apps.

"Simon Kissel" < XXXX@XXXXX.COM >wrote in message
news:438b33c4$ XXXX@XXXXX.COM ...
>Hello.
>Should i add execshieldfix.pas in the executable file only or in the
>executable file and
>in the all Kylix-libraries which are linked with this executable?

Shared objects (.so's) are not affected by the problem. So, you only
need to add execshieldfix.pas to your main executable. If you are using
CrossKylix, you don't need this at all.

More details on my website:
crosskylix.untergrund.net/execshield.shtml

Simon

 

Re:Kylix 3 applications on new linux distros

zeljko wrote:
Quote
didn't found any problem (Fc4,Fc5-devel,Suse-10), you have to include
execshieldfix unit into your app.
Does Kylix de{*word*81} works in SuSE 10?
--
Best regards,
Fikret Hasovic fikret.fbtalk.net
USAID TAMP Senior Programmer
* Firebird Foundation member.
- Join today at www.firebirdsql.org/ff/foundation
* JEDI VCS contributor
jedivcs.sourceforge.net/
* Firebird and Fyracle news
www.fyracle.org
Posted with XanaNews 1.17.6.6
 

Re:Kylix 3 applications on new linux distros

Quote
Does Kylix de{*word*81} works in SuSE 10?
No
 

Re:Kylix 3 applications on new linux distros

zeljko wrote:
Quote
Distro have nothing with de{*word*81}, kernel is problem. AFAIK 2.6.10 is
last kernel known to work.
I know that ;-) I just wanted to know if they fixed (or made some
workaround) kernel in latest distro's...
--
Best regards,
Fikret Hasovic fikret.fbtalk.net
USAID TAMP Senior Programmer
* Firebird Foundation member.
- Join today at www.firebirdsql.org/ff/foundation
* JEDI VCS contributor
jedivcs.sourceforge.net/
* Firebird and Fyracle news
www.fyracle.org
Posted with XanaNews 1.17.6.6
 

Re:Kylix 3 applications on new linux distros

Fikret Hasovic wrote:
Quote
zeljko wrote:

>didn't found any problem (Fc4,Fc5-devel,Suse-10), you have to include
>execshieldfix unit into your app.

Does Kylix de{*word*81} works in SuSE 10?
Distro have nothing with de{*word*81}, kernel is problem. AFAIK 2.6.10 is last
kernel known to work.
 

Re:Kylix 3 applications on new linux distros

Fikret Hasovic wrote:
Quote
I know that ;-) I just wanted to know if they fixed (or made some
workaround) kernel in latest distro's...
nobody should do that just because of kylix , kylix needs updates, not
kernel ;)
 

Re:Kylix 3 applications on new linux distros

zeljko wrote:
Quote
nobody should do that just because of kylix , kylix needs updates,
not kernel ;)
Correct!
--
Best regards,
Fikret Hasovic fikret.fbtalk.net
USAID TAMP Senior Programmer
* Firebird Foundation member.
- Join today at www.firebirdsql.org/ff/foundation
* JEDI VCS contributor
jedivcs.sourceforge.net/
* Firebird and Fyracle news
www.fyracle.org
Posted with XanaNews 1.17.6.6
 

Re:Kylix 3 applications on new linux distros

"Fikret Hasovic" < XXXX@XXXXX.COM >wrote:
Quote
zeljko wrote:

>nobody should do that just because of kylix , kylix needs updates,
>not kernel ;)

Correct!
So long as this attitude prevails, Windows wins.