Board index » kylix » kylix 3 on lfs 6.0

kylix 3 on lfs 6.0


2005-02-22 11:10:01 PM
kylix2
i have problems starting kylix on lfs 6.0.. when i try to start it with "startdelphi" i get the following error
/usr/local/kylix3/bin/delphi: relocation error: /usr/local/kylix3/bin/libwine.borland.so: symbol errno, version GLIBC_2.0 not defined in file libc.so.6 with link time reference
i have newer glibc (Glibc-2.3.4-20040701) than that.. i also have kernel 2.6.8.1..
please help..
thanx
vooood
 
 

Re:kylix 3 on lfs 6.0

vooood wrote:
Quote
i have newer glibc
And that is the problem. Most libraries are not downward compatible.
Removing/Renaming functions is not a rare thing under Linux.
--
Regards,
Andreas Hausladen
(www.kylix-patch.de.vu - unofficial Kylix 3 patches)
(andy.jgknet.de/blog)
 

Re:kylix 3 on lfs 6.0

"Andreas Hausladen" < XXXX@XXXXX.COM >wrote:
Quote
vooood wrote:

>i have newer glibc

And that is the problem. Most libraries are not downward compatible.
Removing/Renaming functions is not a rare thing under Linux.
so is it somehow possible to use both the older and newer versions of glibc or is there a way to use kylix with this version of glibc?
 

{smallsort}

Re:kylix 3 on lfs 6.0

vooood wrote:
Quote
so is it somehow possible to use both the older and newer versions of
glibc
Yes.
Quote
or is there a way to use kylix with this version of glibc?
It is not possible for /us/ because the problem is in a binary file.
--
Regards,
Andreas Hausladen
(www.kylix-patch.de.vu - unofficial Kylix 3 patches)
(andy.jgknet.de/blog)
 

Re:kylix 3 on lfs 6.0

Andreas Hausladen wrote:
Quote
vooood wrote:


>so is it somehow possible to use both the older and newer versions of
>glibc


Yes.
could you give me more information on this?
 

Re:kylix 3 on lfs 6.0

"Andreas Hausladen" < XXXX@XXXXX.COM >wrote:
Quote
vooood wrote:

>so is it somehow possible to use both the older and newer versions of
>glibc

Yes.


>or is there a way to use kylix with this version of glibc?

It is not possible for /us/ because the problem is in a binary file.



--
Regards,

Andreas Hausladen
(www.kylix-patch.de.vu - unofficial Kylix 3 patches)
(andy.jgknet.de/blog)
It might help to install an older version of GCC (say: 3.3.3), which comes with an older C-library