Board index » kylix » Packages

Packages


2005-03-01 04:54:30 PM
kylix2
Is there a possability to compile everything (including the Qt libs) into
the executable file?
If not which libs must I deliver if there is a very old KDE (1.x or
something) installed?
kind regards
Mike
 
 

Re:Packages

Michael Rabatscher wrote:
Quote
Is there a possability to compile everything (including the Qt libs) into
the executable file?
This is not possible because the libborqt.so is a gcc compiled library
that cannot be linked into a Kylix Delphi/BCB application.
Quote
If not which libs must I deliver if there is a very old KDE (1.x or
something) installed?
You must deliver the kylix/bin/libborqt* files.
For more information see:
www.efg2.com/Lab/Library/Kylix/deployment.htm
--
Regards,
Andreas Hausladen
(www.kylix-patch.de.vu - unofficial Kylix 3 patches)
(andy.jgknet.de/blog)
 

Re:Packages

Michael Rabatscher wrote:
Quote
Is there a possability to compile everything (including the Qt libs) into
the executable file?

Not without some help from external tools and voodoo dance ;-)
InstallMade makes compact stand-alone executables. Most of the
packages it makes will work on very old Linux distros as well as on
very modern ones. You may grab the latest version of the installer
from: www.superobject.com/imoe/download.html
Quote
If not which libs must I deliver if there is a very old KDE (1.x or
something) installed?

You may be successful in deploying to very old system, but it depends
if your application is using dynamically linked shared objects (like
for example a sql driver, etc ). Kylix application in this situation
will throw an exception and refuse to work, so it generally limits you
to very simple application. Beside, there are other bugs in old
systems in Linux loader and glibc, related to the mechanism of shared
objects loading which may interference with proper functioning of your
program. Also, it may be necessary to supply (add to the package)
additional libs which are not present on current systems or newer
version. Generally, if you really want and with some tricks you will
be able to run Kylix application on most any Linux system ( with
reasonable boundaries )
juliusz
--
InstallMade - Kylix-specific installer
www.superobject.com/installmade/
www.superobject.com/imoe/download.html
 

{smallsort}

Re:Packages

BCB5
When I uncheck packages in a project, close the ide and come back, they are
checked again. I'm guessing it's not supposed to do that..
 

Re:Packages

Sorry, wrong group
"Ted" < XXXX@XXXXX.COM >wrote in message
Quote
BCB5
When I uncheck packages in a project, close the ide and come back, they
are checked again. I'm guessing it's not supposed to do that..