Board index » kylix » The Alt Gr key does'nt work correctly in IDE

The Alt Gr key does'nt work correctly in IDE


2005-06-05 12:38:56 AM
kylix1
Hello,
I've just installed Kylix 3 professional on my (also just installed)
Mandriva 10.1.
I have a problem in the IDE: the AltGr does'nt work like everywhere else: it
does'nt work in conjunction with another key, but sends a "? character
which comes before the other key, for example I get "?" instead of "[" or
"≤ŗ" instead of "@".
I tried to change the IDE police, I tried to change the key affectations,
nothing solves the problem.
Does anybody already encountered this pecularity?
Jo
 
 

Re:The Alt Gr key does'nt work correctly in IDE

Joseph Holec wrote:
Quote

I have a problem in the IDE: the AltGr does'nt work like everywhere else: it
does'nt work in conjunction with another key, but sends a "? character
try installing the unofficial patches from here there are patches for
that problem.
unvclx.sourceforge.net/download.html
siegs
 

Re:The Alt Gr key does'nt work correctly in IDE

siegfriedn wrote:
Quote
try installing the unofficial patches from here there are patches for
that problem.

unvclx.sourceforge.net/download.html

siegs
Thank you very much, Siegfried, for your answer. I have downloaded the patch
for Kylix 3 and installed it, but it has not solve the problem.
I reinstalled the old files for X11 and I am now trying different solutions.
For example, I found that if I set "xkboptions" to "grp:switch" in the
"xorg.conf" file, then AltGr works perfectly in Kylix, but it does no more
work in others applications as KWrite !!! I'll continue to try different
combinations and will report the results here.
Joseph
 

{smallsort}

Re:The Alt Gr key does'nt work correctly in IDE

When I set "xkboptions" to "grp:rwin_switch" the AltGr key works in other
applications and also (partially) in Kylix: I can get #{[|\]}, more:
with both AltGr and the right win key I can get all the char ~#{[|`\^@]} but
I first get an extra character when I depress the AltGr and RWin keys.
It can be a temporary solution, but it's not satisfying.
Jo
 

Re:The Alt Gr key does'nt work correctly in IDE

Joseph Holec schrubte am Sonntag, 5. Juni 2005 20:34:
Quote
When I set "xkboptions" to "grp:rwin_switch" the AltGr key works in other
applications and also (partially) in Kylix: I can get #{[|\]}, more:
with both AltGr and the right win key I can get all the char ~#{[|`\^@]}
but I first get an extra character when I depress the AltGr and RWin keys.

It can be a temporary solution, but it's not satisfying.
This was very interesting for me, because i was searching for a solution
since SuSE 9.2 was released. All these wellknown changes in XModmap didnt
work for me, dont know why. Now i've read your posting and tried your
solution. It works in SuSE 9.2, but in a little different way:
In all applications outside of Kylix the AltGr-Key works like before, and
inside Kylix now the right Win-Key is working like the AltGr-key should do.
The AltGr-Key is unusable like before inside Kylix.
Its not like it should be, but its much better than before, thanks.
regards, Jens
--
Die oben angegebene Adresse ist OK, wird aber nicht gelesen. Wenn direkter
Mailkontakt gewŁnscht wird, bitte spamtrap gegen jens<punkt>nixdorf
austauschen. Danke.